I have a problem with some Units in my project.

They are functional, they are properly referenced in the .dpr, but I needed to change a component for another type and I am not able to access the DESIGN of that unit. I access the DESIGN of some and not others.

Remembering that: I don't have any errors in the terminal, when I run the project, even the screens with the buggy design work perfectly. Only in development I can't open the DESIGN part to change components.

I'm not sure what is causing this. Do you get any error?
Do you have step by step information how we can reproduce this?

There is no step by step, no error. Only some units, for some reason, do not open DESIGN

With this limited information, I have no idea about what might be causing this.
Are these just code units or form units with DFM & HTML file? Are the DFM and HTML file shown in the project manager? Have you tried to create a new project and add these units (and possibly DFM/HTML file) to this new project and see what happens?
Finally, what Delphi version is this?