AccessViolation in PhoneHeader.RenderHTML

Hi all,
I get from time to time an AccessViolation in TIWIPHoneHeader.RenderHTML in the very first line:
function TTIWIPhoneHeader.RenderHTML(AContext: TIWBaseComponentContext): TIWHTMLTag;
  html, ajaxcall1, submitclick1, ajaxcall2, submitclick2: string;
  leftradius, rightradius, btheight: integer;
  btleftclass: string;
  agent: string;
  agent := String(AContext.WebApplication.Request.UserAgent);

  btheight := 30;

This (only sometimes) happens when I try to access the App with an iPhone 4S (iOS6) or an iPod. I can not determin any specific reason, because there are other times where it works without any problems.

I'm running D2010 and use IW12.2.11 which has improved detection for the latest iPhones (which I needed).

Does anybody have an idea why this could happen?

Best regards,

It seems that this only happens when I run it in the IDE, as soon as I start the exe directly this doesn't seem to happen anymore!

Any way: it would be good to know what it is in order to handle the Exception properly - since it still is an Exception...

This also happens when running your demo directly from the IDE.

I also got a socket error while running the demo app - while having a perfect W-LAN connection, no interruption of local services. In other words: No visible reason for a socket error.

I have not been able to reproduce this issue.

Did this also happen with previous versions of IntraWeb (12.2.8 for example) or is it a new problem in 12.2.11?

This defintily happend in 12.2.9 and 12.2.10 as well. I actually can't remember if this happened to 12.2.8 as well.

I'll do some further testing to see if the issue can be reproduced here.

Does this also happen on iOS5 or only on iOS6?

This happens for iOS5 and iOS6. I have been checking a bit further but could not determine any specific trigger for the behaviour. I tried to keep the enviroment as fresh as possible for the testing: I restarted my system, opened the project,  generated the exe and then ran it from within the IDE (F9). There I got the AccessViolationat the described point.

When after this starting the exe diectly from the Windows Explorer all was working fine. A second attempt via the IDE failed again.

This error come up when starting up, and as the called function implies at a very basic level

Unfortunately the project is a bit too extensive and contains confidential  information so I can't send it to you.

Can this be reduced/isolated to a simpler app with which this can be reproduced?

I will check during the weekend and let you know.