Render Problem


im using XE2 Update 4 with IW 12.2.4 and the iPhone Controls Pack v2.0.1.0.

Im having some trouble while rendering the first region of my application. It seems that the iPhoneFooter is not positioned correctliy. It just looks like it is moved to far to the bottom of the screen.

The problem exists until i switchet throug some other regions and reloaded the app. Only after this the positioning is correct. I've experienced the Problem both on iOS and Android Smartphones.

I have already created another app for testing and the problem did not showed up. So i thought there would be something in my delphi code interfering with the controls, but after removing all my code (Database access, etc.) the problem still exists.

I'm really stuck with this one and I'm hoping someone can help me.


P.s.: The Demo works like it should.

If the demo is working as expected, there's most likely something you are doing different in your own application.
Can you please provide a ready to run sample application that demonstrates the issue so I can further investigate this?

Thanks for your quick replay.

I've uploaded the sample to our webserver. You can download it here:

It contains only the controls an the PageTransition-Functions, but the problem is still visible.

Thanks for your help.

As can be seen in the link to the screenshot below, your sample app is working as expected when tested here.

Can you please let me know exactly how to reproduce this issue and also which device and os version you are using to test the application?

I'm using WinxXPsp3 for development and testing. I've also tried creating a .dll and ran it on a Win2003Server. Same result here.

I'm testing the App on two iPhone4 with iOS 4.3 and iOS and a GalaxyS3 with Android 4.0.4 both with same results.

I have not been able to reproduce this issue.
Is the problem visible directly after running the application?

If possible, please provide a screenshot of the issue so I can see exactly what is going wrong.

Yes, it is directly visible. Here's a screenshot from my Android device:

This could be related to the specific IW version and/or android version you are using.

Have you tried creating a simple app that only contains an IWiPhoneStyle and IWiPhoneFooter control?
If that works as expected, then add all required controls one by one to see when the issue occurs.

Right now, i have recreated the whole app from scratch and all worked as expected until i created a .dll and ran it on my Win2003Server.

So now the app works nicely when starting the IW test-server on my local WinXP machine, but the .dll on the Server is having the same issue than before.

I've created a .dll from the sample app you provided and tested again.

The app is also working as expected as ISAPI.
I'm not sure what could be causing this issue.
Are you sure the .dll on the Server machine was refreshed correctly?
Have you tried renaming the .dll?

I recreated the dll and it is working now.
Many thanks for your help.