WebCore Compiler asking for Licence.lic on MacOS M1, Lazarus

I have been struggling with this. Tried once more just to check if WC already works under Lazarus on the mac. (under windows, it does so-so with the problems other users also experienced at design time)
On my Mac Air M1, installed latest Lazarus 2.2RC, FPC 3.2.2. This is supposed to be compatible with M1, and it actually compiles regular apps, but my sole interest is WebCore.

-loading a sample project, it complains that pas2js is not installed. I looked for it and it is nowhere in the system. Regular internet lazarus projects that also require pas2js can't compile either, so for those I would have to make pas2js some day.

  • I configured the Web Core section in the IDE to look for the webcore compiler that is located at /Bin/macOS64ARM/TMSWebCompiler under my WebCore.
    Now Lazarus can't compile because I don't have any Licence.lic and says I should go to buy a license from TMS.
    I just copied the TMS lazarus component installation folder tree from my PC to the mac, but since there is no mac or linux installer I assumed the procedure is legal and my license is valid on my mac as well.

So my questions:

  1. I understand that my license is valid on my development computers or if I migrate to a new one, right?
  2. What would be the correct procedure to configure and compile in the Mac (x64 or M1) and on a linux laptop? (do I have to install pas2js or are the compilers in Bin the ones to use?)

Regardless if Webcore is working good or not at this time, I guess that it will improve and will be fully usable at some point, bur for now at least I would like to compile something just as it is possible to compile in lazarus windows.


Do you have Rosetta installed on M1?
Our compilers & license generators are still x86 only and require Rosetta to work on M1

Yes, Rosetta is installed. Also, many applications I compiled for intel on my previous mac work on the M1 without a problem ( originally compiled with lazarus, xojo and others).

Compiling is done with the TMSWebCompiler. We have this at this moment for x86, so if Rosetta is installed, this works.
The license generator is also included in the distribution. Also this license generator works with Rosetta. I suggest as a first step to run the license generator and use it with your credentials.
The license permits to copy files to any of your development machines and install and run it.

I looked for the license generator in all places I could: On my available downloads on your site and on the public downloads, on the component install folders for lazarus and delphi (the ones originally installed by the setup), and other places on my computer like the appdata/local and documents folder, including the public documents sometimes used by installers.
Didn't find any license.lic in my windows computer, either, and so far, but my web core apps work fine. The subcription manager does require my credentials, though, but it does not install or download WebCore, just Fnc.
Also went through the pdf documents and there is not a single mention regarding a license generator.
Can you point me to it, please?

BTW, I just saw some mentions in the support center but they refer to TMS server or visual studio code,. My subscription is not all access, probably the license generator is not part of my downloads?

If you cannot find the macOS license generator, it can also be downloaded here:

Tried to download on windows but Windows Defender keeps deleting it with danger messages. Then I downloaded it on the Mac Air M1. Sadly it does not run on Big Sur because it seems it is not properly signed and notarized. This was not required on previous MacOS versions.
I attempted some actions, like signing it myself - also as sudo- trying to force it to open, at no avail.

Just hold down ctrl key and left-click on open - then confirm you want to open the app... works perfectly on Catalina, should be the same on BigSur - finally, save the License.lic file into the dir where TMSWebCompiler is.

Well, of course that was my first choice, but it does not work here. (ctrl-click or right-click, then confirm open) The error message thrown is "you are not authorized to open the application...", which in turn means that it is not signed according to the OS requirements.
I understand that Big Sur has some tight restrictions on that area, and will be tighter in Monterrey, expected to be released in the upcoming weeks. Will test in an older imac I have, that has El Capitan. But that machine is way too old to run many apps.

It finally open.
I followed some of the instructions I found online, stackflow and others but didn't work.
After the options there, I assumed that 777 was best so I chmoded with sudo.
Initially it didn't run, but after the third of fourth try it responded to ctrl click open and confirm. So now am able to open it.

Have not tested generated the license yet, but is probable that it will work now. Will do it tomorrow morning and test lazarus.

Mmh... noted - I tested a couple of weeks in Dec. '20 a M1 mac mini and it was possible at that time to install packages via alt-click. Maybe further (security) updates hardened authorizations. Since you say that you have other macs... well, you can generate license file there and then move it :slightly_smiling_face:

Well, it generated the license in the Mac Air M1 without problem and the compiler works now. The sample app didn't compile, though, but that is because this version of Lazarus itself is not stable and it can't find some source files.
I will have to make a cleanup and roll back to a stable version of Lazarus and FPC since this RC has its own problems.
Thank you!