TTMSFNCRichEditor when I select invisible text

OS: Debian 10 (buster) LXDE
fpc 3.3.1
lazaraus 2.1


Latest available release (Tuesday, March 24, 2020)
my package download and install

when I write text and select it, I do not see what I have selected

Did you check properties


Thank you, it works now.

OS: Debian 10 (buster) LXDE
fpc 3.3.1
lazaraus 2.1


TMS FNC UI Pack  release


TMSFNCRichEditor.SelectionColor (not work)


component TTMSFNCRichEditorEditToolBar
button CUT, COPY
not work

We traced & solved this issue. The next update will address this.

Thank you,
Praise for your work


TMSFNCRichEditor.SelectionColor (work ok)

component TTMSFNCRichEditorEditToolBar
button CUT, COPY, PASTE  for TMSFNCRichEditor not work

I guess this is also on Linux?
Retested here on Windows and works as expected. 


Clipboard is currently not exposed yet on Linux due to missing API calls. We'll investigate this here as soon as possible.

debian buster lxde 64
lazarus 2.1.0 fpc 3.3.1

TMS FNC UI Pack v3.2.2.0

component TMSFNCRichEditor

I can't highlight text.
When I click the mouse where I need to highlight the text, the cursor does not change position.
Does not select text.

now i am not able to check the previous problem

We do not have a debian linux installed here. We use ubuntu.
When you load RTF text with text background color set, do you see this on this machine?

When I have one line of text, I am not able to move the cursor to any word.

Cross compile for win32 (WinXP) behaves the same.

When there is more text, the cursor does not move to the position I selected.


v3.2.2.1 | Tuesday, December 08, 2020

The problem still exists:

  • select text to cursor position
  • Ctrl+C (toolbar copy) exception: IndexOfCachedFormatID: Internal Error: invalid FormatID 0 for clipboard.
  • Ctrl+X (toolbar cut) exception; IndexOfCachedFormatID: Internal Error: invalid FormatID 0 for clipboard.

Unresolved issue from April. Is there no support for Lazarus/Linux?

They probably have some problem, they are serious, I trust them

We are currently still looking into this issue. It's quite complex and we need more time to investigate.


We have fixed the issue with the clipboard. Next version of TMS FNC Core & TMS FNC UI Pack will address this.

I still have a problem, can you write what the plan is.

For now I can't use the component.

It is on our todolist.
Due to heavy workload + situation with remote work due to covid19, I cannot give an exact timeframe.

Thanks Bruno.

Teleworking should be well practiced.
More work can be done.