TTMSFNCBitmapContainer -> doesn't seem to work on Android


I have a similar problem as in the topic: Adding images to a TTMSFNCBitmapContainer

-On the main form there is a TTMSFNCBitmapContainer
-There are TTMSFNCToolBarButton on the Main form and on the Secondary form

  • Every button is connected to the MainForm.TTMSFNCBitmapContainer
  • On Windows platform the bitmaps can be seen on the buttons
  • On Android only the bitmaps on the main form can be seen, but not on the secondary form
  • Interestingly on the secondary form can be seen one bitmap on a button (this is the only one button which wasn't created at design time in the IDE, but at runtime ->
    With Bitmaps.Add(1) Do
    BitmapName := 'Actions_Arrow1Right.svg';

What can be the problem with the bitmaps on Android on the secondary form created in the designer? Thank you!

Can you attach a sample demonstrating this issue?


Its behaviour didn't make any sense:

  • It worked with one bitmap but not the others
  • But when I copied the TTMSFNCBitmapContainer to another project (to demonstrate you) it worked well
    -Then after many hours of fruitless effort I put an FNCObjectInspector on the form and to my greatest surprise, although the TTMSFNCBitmapContainer in design time showed 5 bitmaps, the FNCObjectInspector at runtime showed 7!
    -I deleted the TTMSFNCBitmapContainer and created a new one which works.

But the question is, for how long? Can it be that after a time it will "get crazy" again and behave erratically? What could have caused this?

Thank you.

It's the first time we have a report of this behavior. I suppose it's a one off. If it pops up again, please let me know.