I am working with TTMSFNCBitmapSelector (and TTMSFNCBitmapPicker) with a TTMSFNCBitmapContainer. in Delphi

I created the Container and loaded 3 bitmaps of different sizes, each for a user selected app font size.

In my Win64 test app, I dropped the Selector and Picker components on the form, and set each BitmapContainer property to my container.

The Selector and Picker Columns and Rows are set to 4 and 4 by default.

When I run the app, no selections appear in the Selector or Picker.

So, what do I do? 

Do I use an OnDraw event(s) to get the Container bitmaps to appear in the Selector, Picker.

Do I add Items to the Selector, Picker and use the bitmap name to associate the item with the Container items? FYI, when I try to do this I get an A/V in rtl250.bpl.

I looked for examples in the demos but could not find one.

Perhaps there is an example for a similar control?

Win 10 64 Build 16299
RAD Studio Tokyo 10.2.3 (Delphi)
Win 64 App
FNC Components, Core as of May 8, 2018
This is my first attempt using the Selector, Picker,Container
Thanks for your help!


You need to connect the BitmapContainer to the TTMSFNCBitmapPicker / TTMSFNCBitmapSelector and then manually add items to the items collection. Each item has a BitmapName property that can be set to the same name as loaded in the BitmapContainer.

OK, thanks for your help!

As with other BitMapContainer related controls, I thought the bitmap name was the link.

As mentioned previously, when I tried tried to type the BitmapName in the Object Inspector I would get the access violation (A/V) in RTL250.bpl. I got the same error when I tried to do the drop-down.  I thought I had missed something somewhere.

The work-around has been to PASTE the BitmapName into the Object Inspector, This works great, problem solved.

There remains the A/V issue. If it's of any help I can send my little test project. Maybe you are already aware... If I can be of any help, please me know.



Yes, a sample demonstrating this issue would be helpful.

I can pack it project, or .pas/fmx into zip file. How do I attach to reply?