TMSFMXMemo do not accept characters on Linux

Hi ,
I have an application working on both windows and linux , it use a TMSFMXMemo to edit ini files.
It was working well before but i cannot point on which update the Memo refuses characters , the strange thing is that the arrow keys and the delete key react but not basic characters like a...z.
On the same application i also use a standard memo which work fine.
I created a new application from scratch with only a TMSFMXMemo and behavior is still not good.
What am i missing ?


We'll investigate this here as soon as possible.

Please note that TMS FMX UI Pack does not have Linux support, Linux support is only available in TMS FNC UI Pack.

Hummm , so far i haven't tried any other components from FMX UI PACK but everything compiles fine with any warning or so ....
What makes me confusing is that it was working with previous versions ...
I'll have to go back to these versions.

It compiles, but there are several parts that are not working (such as the XLS export and the webbrowser). We adapted TMS FNC UI Pack to make it work, and then officially announced FMXLinux support for FNC. Nevertheless, we have meanwhile further investigated this here for TTMSFMXMemo and noticed the KeyDown event is not triggered, therefore the keys are not processed. To process keys, we need to add the ITextInput interface. I have sent an incremental source update for testing purposes.

Hi, Thank you very much , it works !!! :+1:

Do you have any FNC component like FMXMemo ?

We currently do not have an exact copy of TTMSFMXMemo for FNC. We do have the TTMSFNCRichEditor ( and the TTMSFNCWXHTMLMemo ( that offer similar functionality. The TTMSFNCWXHTMLMemo is based on JavaScript/HTML. Below is a screenshot