TMS Installer problem

Hello, today i decide to go Delphi 10.4.2
Now i am installin BCL + Aurelius but getting same error after installing them
"Can't load package
The specified module could not be found. Do you want to attempt to load this package the next time a project is loaded."
Same for dcltmsbcl270.bpl.
This directory is not in search path but i think it was supposed symlinks to be made to
Which are in search path however there was nothing here.
Uninstall.json contain info about symlinks but they does not exist if i copy files manually to corresponding directory everything works fine.
Any suggestions why symlinks was not created ?

Maybe this topic can help you out?

It was fresh install of Delphi 10.4.2 so folders was absolutely empty.
Previous version was 10.3 RIO

Did you try the described procedure to see if it solves the issue? Also make sure you install using the same Windows users you use to run Delphi.

As I wrote up, it was fresh install of Delphi 10.4, directories was absolutely empty, there was noting to delete. Only think which help was to manually copy files there.

It's not clear to me if you solved the problem or not? Also you didn't answer either of my two questions.

Problem with installer still persists if you try to do it with installer its not work. If i do things manually it works but that does not fix problem with installer.
I answered to your questions twice.
There is nothing to delete on ${BDSCOMMONDIR}\bpl and also \bpl\Win64 folders when i open command prompt with admin rights because they are empty.

Are you running the installer with the same Windows users you use to run Delphi?


I'm running out of ideas. I have never seen such issue - symlinks not being generated without any further error message - in all those years.

I have question does somewhere in installlog you write entries for creating symlinks ?

The full installer log is located in folder <installdir>\setup, and it does mention the symlink generation operation.

Found it symlink creation pass without an error in log.
However symlink does not exist.
I will have brand new PC tomorrow and will go t\rough all of setup process to check things.

1 Like