TColumnComboBox loses ItemIndex (set -1)

D12, TMS VCL UI Pack XE15

I see with my own eyes that sometimes, on a Windows 10 pc, during the FormCreate all the TColumnComboBox lose their ItemIndex. The ColumnComboBox are popolated at runtime, using a function that adds several values and set the default one; if there is not default value, the function sets the first one (ItemIndex = 0).

As I said before, sometimes on my client's PC, after the FormCreate it takes -1 as ItemIndex, but the ColumnComboBox has the ItemList correctly filled.

Other times, everything works perfectly (same PC, software, user, conditions).

I wouldn't want there to be an event beyond my control that resets ItemIndex to -1 (as it is at design time).
By the way, there is no OnChange event.

Another hypothesis concerns the behavior of the new object included in the D12 version of the TColumnComboBox: a TTimer. It may also explain why this bug only occurs every now and then.

NB: the same software with D11 and previous TMS UI Pack worked correctly.

Thanks in advance

Can this be reproduced with the TColumnComboBox demo?

I tried to reproduce it with the demo, even releasing a small project to the customer, but unfortunately the demo always worked correctly.

I can't explain it, but my intuition tells me that there is a problem with the management and optimization of events, between FormShow and FormActivate (which can be launched several times), such that at a certain point, despite already having the values loaded, the designtime ItemIndex is set, which is always = -1 (since there are no items)

I'm afraid that in order to properly investigate this, we will need details how to reproduce this as so far we have not seen this here and we have not received a similar problem report from other users.