TAdvTwitter - Strangeness

Using the twitter demo program. My twitter.ini file contains the Access Tokens. I connect to Twitter and all is fine.

I now click on "Remove Access" so it deletes the Tokens from twitter.ini.

Next I try and connect again.

The Auth form that appears says:

"There is no request token for this page....

I'm sure it used to just ask me to confirm access. Has anything changed anywhere.

I am still using the previous cloud version (not


We are not aware of any issues with the Twitter API at this time.
Can you please make sure your dev app key and secret values have been entered and that your system clock is set correctly (Twitter API uses a timestamp check for authentication)?

If the problem persists, please enable logging and provide the automatically generated log file after the issue has occurred so I can further investigate this.


  AdvTwitter1.Logging := true;
  AdvTwitter1.LogLevel := llDetail;
 (The log file is automatically generated in your machine’s documents folder)

It tried regenerating the keys, but no joy.

Tried a complete new Twitter App, just the same.

Where do I send the log file?

Did you also check your system clock?

You can send the log file to mailto:help@tmssoftware.com

It seems you are correct. For some reason the clock on my computer was an hour behind.

Also noticed that in my Twitter account, the Time Zone was set to UTC+1. It should be UTC+0

Fixed both and all is now fine again.