TAdvTreeComboBox eats the Enter/Escape Key.


When I have focus on the TAdvTreeComboBox (ReadOnlyTree) and it's drop-down menu is closed, I press escape but the dialog doesn't close (the cancel button has the Cancel property set to true). Same with Enter for the default button, nothing happens. It seems that control is eating the Enter/Escape key even when the dropdown is not open, that seems like a bug. It should allow it to pass through when the dropdown is not open.

We traced & solved this issue.
The next update will address this.

This issue still exists in the latest update.

I could not see an issue with Escape.
We fixed the issue with Return key.
In next update, attached test project will behave as expected.
Project1.zip (5.6 KB)

I was going to test your project under Delphi Community Edition since I use C++Builder but the install said it failed, on startup it said it couldn't find the projects, so I looked at install.txt (you need to say where that is because it's under hidden folders), and then I read install.txt, but trying to open a package there is none for D11 just the older ones? Do you have C++Builder and I can send small project too to test with?

Uploaded sample built with C++Builder - Click open dialog, then try to press esc/enter - doesn't do anything. Included .exe built if you don't have C++Builder.

TestAdvTreeCombo.zip (124.2 KB)

With latest internal code update, this works fine.
So, next release should address this.

yes, fixed, thanks, BUT a new issue exists with the text overwriting the icon. The text in the attached pic is "uncategorized" - you can see it put the text under the icon instead of adjusting (this is a regression because prior versions worked). To be clear that is the combobox with the selected item.

We've seen & fixed this regression. Next update will address this.