TAdvMemoCut etc. missing?

I just updated to latest TMS Component pack (was using and the source doesn't compile (C++ Builder 2010).

TAdvMemoUndo not found...
TAdvMemoCut not found...

Actions which the AdvMemo was using are missing.

What changed? Are these actions no longer required or have they been replaced with something? I can see they still exist in the source code so what happened? Has define file changed?

Do you have all  packages of the TMS Component Pack active (checked) in the IDE? There should be 5 packages. See IDE Component / Install Packages.

All are checked. I pretty much did just uninstall of the old pack and installed new pack. Installation went without problems, no errors or anything. And after the installation my code I had which was using TAdvMemo with its associated actions no longer compiles.

In fact, the AdvMemoCut, undo etc... do not even appear in the action manager when I use "new standard action" in action manager. They used to appear in earlier release.

The only actions which appear in action manager are "Planner" and in old version there is also "AdvMemo" section with the actions which are supposed to be there and which is missing from the new updated version of component pack (which is also the reason for the compilation error why it cannot find these components).

Tried also to create a blank new project and the actions do not appear in that project in action manager either.... all 5 packages are checked in the IDE install packages.
They do not appear in standard actions of action manager. Tried also new Delphi project, same result so it is not just C++ Builder 2010:

All checked in IDE:

We have not changed anything with respect to actions.

TAdvMemo actions are defined in AdvMemoActions.pas and these are registered in the IDE via AdvMemoActionsReg.pas. 
These files are in the package TMSD2010.DPROJ. If this package containing these files is installed and active in the IDE, I cannot see a reason that these actions are not available.

I am not describing what you might want to be or what you claim to be, but what actually is the result of installation.

I tried to uninstall and installed and the actions reappear in the IDE (TActionManager). is the latest version I have which is more recent than I had, so clearly some change between and has occurred which you may have forgotten. If you cannot see the reason why they are not available I definitely cannot too... I just see they are gone so with it looks like this:

When is installed back, the AdvMemo actions are gone.

  • can you please try to install on your own copy of RAD Studio
    2010 and test this. I know it is archaic version and I plan to update it
    but cannot do that yet due to dependency on one other component which I
    have to entirely remove from my software as it would cause issues with
    more recent installation of RAD Studio.

We will investigate.
To help you solve the issue right-away, can you open TMSD2010.dproj, add AdvMemoActions.pas and AdvMemoActionsReg.pas to this project file and compile & install it?

Following your guide,it appears that adding these 2 files to the TMSD2010.dproj fixes the problem and actions are now again available in the IDE and a few more actions are now available as well, I assume those were added in the meantime.

When can we expect updated version of component pack with this fix built in? I would assume something got messed up when updating the project file for the 2010 version.

We'll look to schedule an interim update in the coming days before the normal scheduled update of July 24.

Thank you for your help and looking into this!