Still can't install when reaching Linux64

Downloaded the latest March 1st 2022 version hoping the fix was present for XData, Sparkle that don't install when selecting Linux64.
I've been told to install everything but Linux64 and then compile Linux64 manually and that it's a Delphi bug.
Why do all TMS Biz apps install correctly prior to mid-February then if it's a Delphi bug?

Compiling Sparkle for Linux64 by hand says it's ok. Then you install XData, same problem. Then you want to compile XData Linux64 manually and it doesn't work because it doesn't see XData Linux64.

Now I don't want to go through the entire mess of adding all lib and search path for each package each time I install one.

I don't see how this could be a Delphi bug when it was working correctly two versions ago and Delphi didn't move one inch.

Can we have a fix? The installer is supposed to install smoothly without manual interventions.

I revert back to my previous VM now in order to use those tools.

Hi Steve,

this works as an interim solution: Sparkle Install Delphi 11 with updates: Workaround

1 Like

It is a Delphi bug. The workaround pointed by @Putzich_Andreas works fine, also. Delphi 11.1 (update 1) is right around the corner, and hopefully it will fix the issue.

Hi Putzich and Wagner,

As said, I've tried that. It compiles Sparkle fine to Linux.
Then I copy the release folder onto a debug folder in the same place.
Compile XData and it's the same problem. Doesn't compile if I include Linux64.

I'll wait for the coming Delphi 11.1 and if it doesn't stick, I'll stay with my December 2021 VM and continue until there is a fix.


Still doesn't work. Worse than before.
See the thread you provide here (above) for more details.