Error when installing TMS Data


For a PoC I wanted to try making a Client application which uses TMS Aurelius through a TMS XData server, so today I started installing TMS XData which requires TMS Sparkle, so I installed that as well.

After installing TMS XData the TMS XData Design-Time package loads with the error The procedure entry point @System@Net@Mime@%TAcceptValueListBase__1#p32System@Net@Mine@TAcceptValueItem%@bcctr@qqrv could not be located in the dynamic link library C:\Users\Public\Documents\Embarcaderro\Studio\19.0\Bpl'sparkle250.bpl

Am I missing something somewhere?

Hi Stefaan,

Are you trying to install the trial version, using Tokyo without all updates? 
 There are dcu binary incompatibilities between updates of Tokyo, TMS XData trial for Tokyo requires the latest updates applied, otherwise it might be not binary compatible.

Hi Wagner,

No ... I have a TMS All Access subscription and installed everything through the TMS Subscription Manager v2.0.1.1

Well, that is really strange then. Could you please first try to recompile all the packages?

In the Start Menu, for each TMS Business product there is an entry there and there is an utility "Package Rebuild Tool".
I will ask you to run that tool for TMS Business Core Library (BCL) then TMS Sparkle, in that order.

Also please check if you don't have duplicated files from BCL/Sparkle in your hard disk. Most common files to look for are tmsbcl250.bpl, sparkle250.bpl, tmsbcl.dcp and sparkle.dcp.


Rebuilding the packages didn't solve my issue. Checked for duplicate files and the only thing I could find was a sparkle250.bpl 32 bit and a 64 bit version in their corresponding directory. 

I did find 12 versions of sparkle.dcp for different OS / Build Config combinations in their respective ~\Documents\tmssoftware\TMS Sparkle\Packages\DelphiVersion\OS\BuildConfig folders but I don't think that should be a problem.

 Already tried uninstalling / reinstalling as well to no avail.

Stefaan, could you please contact us directly through e-mail so we can setup a way to solve this issue?

Sent you an email Wagner.

Same problem here.
There is a solution?

We got a support issue via e-mail with a customer that had the same problem and really went deep to find the cause and solution of this problem, and he was able to solve it. Here is what he reported:

“The good news is that TMS Sparkle, XData and Echo work without problems under RadStudio Pro.

Just removing Expert, IDE Fix, TestInsight didn’t really help to install XData which still
showed the No Entry Point bug.

Then I fully uninstalled RadStudio Tokyo, wiped everything from its directly, the registry,
and all traces in My Documents as well as Users[…]\ etc.

Then reinstalled with the latest ISO, now all is fine.

So what I think might have been the problem is the full uninstall/reinstall of RadStudio each
time they release a new version: 10.1, 10.2, 10.3.
On the forums, after I complained, Embarcadero told me I didn’t need to uninstall, just
reinstall the new release on top of the existing one. It did work, I didn’t need to reconfigure
everything and reinstall all 3rd party components.
But I’m now sure that at some point, things got screwed on the way, and made XData not
compatible anymore. It could have been any other kind of components.

So if someone comes with the same problem, my advice would be to
1- compile/install your components for each specific IDE separately should they have several 
RadStudio versions. I did Tokyo 10.2.3 first, then Delphi 2010 separately, not together
2- fully uninstall RadStudio, clean all directories and the registry branch, reinstall, and start with TMS

Wow, now I’m saving my precious VMWare machine :-)
At least it works and now I’m just going to enjoy your wonderful tools! 

Wagner, after a complete uninstallation, folder cleaning, and a new installation of Delphi 10.2.3, the problem has been solved.

Thank you.

Thank you for the feedback, Ronaldo.

Just a little update ... brand new Virtual machine, installed Delphi 10.3 Rio and everything installed as expected.

Thanks, Stefaan.