Setup of FNC Core fails

See log attached. Thank you!

Removed due to sensitive information.

There is a linker error for mac OS 64 bit, if you are using macOS, please make sure to configure the SDK. If not, then please ignore this error.

I have the "same" problem.
I have neither the Android nor the MAC platform installed.
It's the same problem as with the VCL package, the installation routine doesn't seem to be optimal yet.

One can ignore the errors on every FNC-Product that is being installed - and it feels as if up to now everything works fine.
But in the other hand also compiling/installing the Client-Editor for the IDE s not possible due to the same error...

Up to now the setup has worked ok, so why there are errors now, is out of my scope. Additionally, subsequent compiles of the other FNC products fail. And - worse - the IDE throws now erros on startup about missing bpls.

The previous iteration of the installer didn’t detect those errors and therefore the installation didn’t provide an error page even though it were the exact same error messages as before. So right now, the error detection is more sensitive and will produce failed build error page. It’s strange that the compiler is available in the bin folder of your RAD Studio installation even though you have not installed the platforms. The installer checks if the compiler is available. So only thing I can think of is that the environment variables and library path is not properly set up even though the compiler is available and therefore produces the error message.

We’ll open investigation asap.

Meanwhile just ignore the errors and install every FNC product like you would do with previous iterations and see if there are errors in the IDE upon opening and compiling for the platforms you own. I would expect to not have any issues after installation.

I have installed the Mac OS platform, that is why the compiler is there.

If you recommend configuring the SDK, may I ask: This is my dev machine at home with no Mac available. So I think, I can not add the SDK. Can I?

Unfortunately, when the compiler is there, it will try to install. In the latest version of RAD Studio the macOS platform needs to have an active SDK otherwise it will indeed throw errors. What you can do at your develop machine is to import the SDK, then export it (there is an option in the SDK Manager), then import again where you need it. It should compile, you do not need a mac for installing the components, just an SDK.

Uum. I find the import option - but where do I find the SDK?
And what do you mean by import/export/import again "where you need"?

I mean, you need to have a mac to import the SDK. Since you don't have a mac then that's not going to possible. I misread and thought you had access to a mac on another machine/location and that you could then copy/import the SDK. I have now added a version of the SDK for you to import. You can download the file and click on Import, select the .sdk file from 1). I hope this is sufficient for compiling the packages. If it prompts for connecting to the mac, then cancel that, and then you'll need to extract the contents of 2) to this folder: C:\Users[UserName]\Documents\Embarcadero\Studio\SDKs

  1. (1.2 KB)


Great! I'll give it a try.

Nope, that did not work. Import wants a connection to the Mac and simply unpacking does not help either. The error messages are the same as before.

So, we uploaded a new version of the installer, however the version number of TMS FNC Core remains identical, you can redownload the same version and see if it pops up errors or not. Note that the previous version of the installer automatically added library paths to the registry, so you might need to remove them manually before starting the installation.

The registry keys are located under: Computer\HKEY_CURRENT_USER\SOFTWARE\Embarcadero\BDS\22.0\Library

You can remove platform keys that you didn't use initially such as OSX64.

I have just installed version of the TMS VCL UI Pack without any error messages.
With the new FMX UI version the error message still appears

If this concerns a compile error due to a framework/target you haven't installed, then ignore it.