Installing FNC Core faild with 'RTL not found' in logfile

I tried to install the newest Version of FNC Core (from 20.03.2023) but the installation failed.
In logfile there are: "error E2202: Required package 'rtl' not found"
Other Packages did install corectly.
Delphi Compiles my Projects without an error.
Also the Demo Projekts from fnc Core compiles and run.

I dont want to reinstall Delphi because i had to reinstall all the TMS Packages with all the many Questions while installation (unistall yes,install yes ... yes ..yes and at the end i had to unclick all the checkboxes). This is very timeconsuming if i had to install 10 or more packages.

Is the error related to a platform that you are going to use? If not then you can just ignore the error.

The only Platform i use is Delphi 10.4 mostly VCL and sometimes Android.
The Problem is that i cannot install the other FNC Packages as long as Core is not corectly installed.
FNC Core say it is not installed but it is working.

Please read this

The Problem is that i cant install any FNC Packages before FNC Core ist Installed corectly so i cannot install any Updates from FNC.

Picture of installed Options (at first try i had only Delphi Windows installed)

This is a fraction of the Error in LogFile:
Der Buildvorgang wurde am 23.03.2023 17:25:20 gestartet.
Projekt "...\AppData\Local\tmssoftware\registered\TMS FNC Core\FMXTMSFNCCorePkgDXE13.dproj" auf Knoten "1", Build Ziel(e).
Das Verzeichnis "...\AppData\Local\tmssoftware\registered\TMS FNC Core\iOSDevice64\Release" wird erstellt.
C:\Program Files (x86)\Embarcadero\Studio\21.0\bin\cgrc.exe -c65001 "FMXTMSFNCCorePkgDXE13.vrc" -foFMXTMSFNCCorePkgDXE13.res
CodeGear Resource Compiler/Binder
Version 1.2.2 Copyright (c) 2008-2012 Embarcadero Technologies Inc.

Microsoft (R) Windows (R) Resource Compiler Version 6.0.5724.0

Copyright (C) Microsoft Corporation. All rights reserved.

Die Datei "FMXTMSFNCCorePkgDXE13.vrc" wird gel”scht.
C:\Program Files (x86)\Embarcadero\Studio\21.0\bin\dcciosarm64.exe -$D0 -$L- -$Y- --no-config -B -Q -Z -TX.a -AGenerics.Collections=System.Generics.Collections;Generics.Defaults=System.Generics.Defaults -DRELEASE -E.\iOSDevice64\Release -I"c:\program files (x86)\embarcadero\studio\21.0\lib\iOSDevice64\Release" -LEC:\Users\Public\Documents\Embarcadero\Studio\21.0\Bpl\iOSDevice64 -LNC:\Users\Public\Documents\Embarcadero\Studio\21.0\Dcp\iOSDevice64 -NU"...\AppData\Local\tmssoftware\registered\TMS FNC Core\iOSDevice64\Release" -NSSystem;Xml;Data;Datasnap;Web;Soap; -O"c:\program files (x86)\embarcadero\studio\21.0\lib\iOSDevice64\Release" -R"c:\program files (x86)\embarcadero\studio\21.0\lib\iOSDevice64\Release" -U"c:\program files (x86)\embarcadero\studio\21.0\lib\iOSDevice64\Release" --description:"TMS FNC Core for FMX" --linker-option:"-arch arm64" -JL -NH"...\AppData\Local\tmssoftware\registered\TMS FNC Core\iOSDevice64\Release" -NO"...\AppData\Local\tmssoftware\registered\TMS FNC Core\iOSDevice64\Release" FMXTMSFNCCorePkgDXE13.dpk
Embarcadero Delphi Next Generation for iPhone ARM64 compiler version 34.0
Copyright (c) 1983,2020 Embarcadero Technologies, Inc.
FMXTMSFNCCorePkgDXE13.dpk(32): error E2202: Package 'rtl' wird ben”tigt, konnte aber nicht gefunden werden [...\AppData\Local\tmssoftware\registered\TMS FNC Core\FMXTMSFNCCorePkgDXE13.dproj]
Die Erstellung des Projekts "...\AppData\Local\tmssoftware\registered\TMS FNC Core\FMXTMSFNCCorePkgDXE13.dproj" ist abgeschlossen, Build Ziel(e) -- FEHLER.

Fehler beim Buildvorgang.

"...\AppData\Local\tmssoftware\registered\TMS FNC Core\FMXTMSFNCCorePkgDXE13.dproj" (Build Ziel) (1) ->
(_PasCoreCompile Ziel) ->
FMXTMSFNCCorePkgDXE13.dpk(32): error E2202: Package 'rtl' wird ben”tigt, konnte aber nicht gefunden werden [...\AppData\Local\tmssoftware\registered\TMS FNC Core\FMXTMSFNCCorePkgDXE13.dproj]

0 Warnung(en)
1 Fehler

Maybe your Error Sensitivity is too sensitive?


Yes, the error detection is currently too sensitive, so we are investigating this here. For now, just ignore the errors related to the other platforms and continue with installation, even though there is an error page, it should not prevent from finishing the installation and installing the other products. They will produces the same error, but this was the case with the older installers as well, the difference is that the new installers will prompt an error page while the older ones didn't.

OK i will wait until you found something to avoid this.
So i do not use FNC for a while.
Waiting for the next FNC Core Update.

So, we uploaded a new version of the installer, however the version number of TMS FNC Core remains identical, you can redownload the same version and see if it pops up errors or not. Note that the previous version of the installer automatically added library paths to the registry, so you might need to remove them manually before starting the installation.

The registry keys are located under: Computer\HKEY_CURRENT_USER\SOFTWARE\Embarcadero\BDS\22.0\Library

You can remove platform keys that you didn't use initially such as iOSDevice64. It should only contain the search path with our keys. We are also uploading the other products as we speak, they should be available tonight or tomorrow.

I tried to remove all "FNC Core" from the Registry-Library Entries but TMS Subscription Manager did not show the Cloud for Downloading.
I will wait till you make a new Version.
It is not Timecritical.
Thank you for trying to help.

1 Like

They will not show up in subscription manager version number has not changed, best approach is to download them from the website at the My Products page