New VCL UI Pack Kanbanboard

Hello TMS Team,
There's the error again. After installing the current VCL Component Pack 10.8,2.2 the Kanbanboard does not work again. the same error as last time. When moving the entries from one column to another I get a runtime error. I checked my Skia version. This is the most recent (3.4.1).
I created a new VCL application and just only attached the TMSVCLKanbanboard component.
I tested it with and without skia.

Which error do you get exactly?

Hello Pieter,
in the screenshot you can see the exactly error message after moving an item.

If you press break, on which line does it stop?

It stopps at line 6179, system.classes Unit (see Appendix)

Does this just happen with the default kanbanboard? we tried it here but couldn't reproduce this. can you attach a sample?

I send the Answer to your Mail Address. Because I can't send here the compiled Test Application.

We are unable to open compiled executables here. We really need a test application with source code. So we know the settings you have in your component.

Hello Pieter,
Have you already been able to determine where the problem lies? Urgently need a solution, because I can't get any further with my project, or I have to replace the Kanbanboard with something else.

I asked for a test project with source code, because we cannot run executables here due to internal policy. Please attach a simple example here that demonstrates the issue. We are still not able to reproduce this here with a default kanbanboard on the form. It's important to know the settings. (95.8 KB)
Here is a test program. Is a form with a Kanban board. No other settings

I can also confirm the error.
It is enough to drag a TMSFNCKanbanBoard onto the empty form and start the application. It does not matter if it is a FMX or VCL application.

I can still move the first entry without error, but when I move a second (different) entry, the error message appears. I have tested with the current version (TMSFNCKanbanBoard - version, FNC UI v4.1.0.1)

Yes, it's exactly the same.....
But can anyone now say where the mistake lies? I think the item index is not set correctly.

What else I noticed:
If I move the entries from left to right, it always works (in the example e.g. from "Backlog" to "In Progress"), but if I move in the opposite direction ("In Progress" to "Backlog") the software crashes.
It seems to be effectively problems with the indexes

I'm not sure if the bug was "built in" recently, I haven't noticed it in my main project in the past, currently it pops there too though.

We are able to reproduce this here and are currently looking for a solution.

We managed to fix the issue. The next version of the TMS VCL UI Pack will address this.

Hello Pieter,
I have installed the latest version ( of the FNC Component Pack. The Kanbanboard now runs perfectly. Thank you for your work and commitment!


This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.