New problem with WebCore and Sphinx

Hello Wagner,

I have now installed your "Simple demo" on my host server.
Have transferred all directories 1:1 to be on the safe side. In the demo I set all the "localhost" references to the server host IP. I start the DemoServer app on the host server. Then I enter the following "https://ip-host:2001/tms/webclient" in the client PC. All I see is a white web page.

When I open the developer environment of the Bowser, I see that the app is trying to open the Sphinx "openid-configuration" on the "localhost".

If I copy out the line, replace "localhost" with the host IP, the json script is displayed correctly.
Therefore, I suspect that it should not be "localhost" here, but the host IP.
But nowhere can I find out why?
Throughout the project, I use ONLY the host IP and no localhost!

Have you ever tested the demos on a real server client environment? If I test the demo on my development machine only under the localhost, everything runs wonderfully.

Have you any idea?


Of course, to adapt it to production environment you have to change the settings correctly, like you tried to do. It might be different ports, different IP, a SLL certificate might (should) be used, etc..

The mentioned failed request, if I get it right, is defined by the Authority property of the TSphinxWebLogin component. Have you set it accordingly, via object inspector? What are the settings?