Wrong ".well-known/openid-configuration" path

Hello Wagner,
My WebApp now starts fine.
I start the server application on my host server and the Client Web-App on any PC, smartphone or Tab.
Login with Sphinx.
I can create new users and then register them. Send eMail to the user with there confirmation-token. All works fine.

However, if the user wants to login, then get the error message "Undefined" from Sphinx

When I look at the error in the browser, I notice that ".well-known/ openid-configuration" is called with a wrong directory. The directory "localhost:2001/tms.... instead of "localhost:2001/app...

But I don't have any reference to "tms" in all my source code. before I run the "SphinxWeb.login" I created the parameters as follows:

SphinxWebLogin.Scope:='openid email';

As I said, neither in the source code nor in the components do I have a path reference to "tms".

1 Like

Is it maybe a cache you? Can you clear the cache and do a hard reset?

Is it something a configuration in some properties? Have you searched for the tms text also in DFMs?

Have you checked my sample project I sent in the other support topic? It was working for me. Is it working for you?

Do you have a sample project reproducing the issue?

Hello Wagner,
i have clear the cache and also make a hard reset. Nothing change.
I've now gone through all the possibilities.
Unfortunately, I just can't get anywhere. After logging in, I now get the message that the page was not found:

I've created a trial version with a server version running on my host server. On the server app, the button must be pressed to start the dispatcher. The ClientApp should only be started from a PC, tab or smartphone.
On a PC, tablet or smartphone, the app can be launched by entering the host IP.
The Sphinx login screen will be displayed and a new user can be created. Likewise, the user can log in after that. So far, everything is going perfectly.
But after that I don't get anywhere. I don't get a display of the login data.
Instead, an error message.

Here is my demo app. I started the server app on my test host. IP:
The complete demo app here as a ZIP file
TestApp.zip (1.2 MB)

I found something:
After the correct Sphinx login, the user is still NOT logged in.
The "Check Login Status" tells me "User is not logged in".
How is this possible, if the e-mail address and password are recognized as valid?

Please refer to: Cannot use the Sphinx login in a Webcore applicaion - #16 by wlandgraf

You should change properties in object inspector, not from code.
If you change properties from code, then you have to explicitly call Login after it, so it handles the callback URL and perform the login operation.