FNCMaps marker icon not showing


I am using a local .png file for marker icons, which was working OK using FNCMaps v3.0.6.1, but after upgrading to v3.5.0.1 the markers (and icons) are no longer displaying on the map.

I checked the TMS demo and the markers with TMS icons show on the map just fine (using the icons from the TMS web site).

But when I changed the icon location in the demo to my local png file at 'C:\Users\name\Documents\TrainIcon.png' the markers disappeared.

I also tried using the reference 'file:\C:\Users\name\Documents\TrainIcon.png' in case that helped (from an old help topic for WebGMaps). This didn't work either.

Any hints why the updated version of the FNCMaps is not able to find the icon file, whereas the older version of FNCMaps worked OK? Have I forgotten to set a parameter in the IDE properly? (perhaps when I replaced my FNCMaps with the new version). BTW I am using TTMSFNCGoogleMaps


Can you set LocalFileAccess to true programmatically?

Thanks, that solved it (I'd forgotten to set that parameter when I updated the FNCMap)

1 Like