FNC core install on VSC


I have installed the FNC components in delphi 10.4.2 and I am using it without problems, in VSC when installing it gives me the following error:

My OS is Linux Mint 19 x64 and the VSC is 1.59.1

PS: TMS WEB CORE installed without any problems.

Can you help?


1 Like

Can you check in the source code, if there are copyright or other special symbols? alternatively, you can change the file encoding for the source files to UTF-8 and then recompile. We'll check here internally if the files are properly converted.

I experienced exactly the same issue on my Linux Mint 20.2 Cinnamon installation. Did you copy the files from a Windows installation?

Yes, that's exactly what I did.
I haven't had a chance to validate with Pieter's suggestion yet, maybe this weekend.
In the meantime I'll continue the work on a Windows VM....

Did you try to run the installer directly using Wine? That's what I tried first, but I couldn't manage that the installer connects to the tms license server to validate, so that didn't work. Mr. Fieren told me that I just have to allow a http connection on port 80, but I couldn't make it work.


I now see at the screenshot, you are compiling the VCL packages, but you only need to compile the TMSFNCCoreWEB.dproj, which is the Visual Studio Code specific WEB package. the other ones do not need to be compiled.

Hi Peter,

the same error messages coming up when compiling this package under Linux Mint

We have seen this and are currently applying a solution. To workaround this, please change the file format from ANSI to UTF-8 in editplus, or notepad++