FlexCel error after having the last update- class TAdvGridEEcelExport is not found

Dear All, after installing the last version of TMS FleCel (dated 21.09.2022) this error appears.

Reinstall seems giving the same results.

Please help!
Many thanks in advance.

After reinstall bpl from RadStudio -> Komponente -> Packages installieren

the companent is appeared, but is still having errors with compilation:

[dcc32 Fataler Fehler] ModTools.pas(9): F2051 Unit UAdvGridExcelExport wurde mit einer unterschiedlichen Version von FlexCel.Render.TFlexCelPdfExport compiliert.

Please help!

VCL Grid Excel Bridge is of 09.09.2021 (latest for now)

Whenever you reinstall FlexCel, you also have to reinstall the Grid Bridges, so it gets recompiled. Have you reinstalled the grid bridge after installing FlexCel?

Hi Adrian,
thank you for your comments
yes, I did reinstallation of the grid bridges. Then compiler started to cleim something like this:

AdvGridWorkbook.pas(812): F2051 Unit UAdvGridExcelExport wurde mit einer unterschiedlichen Version von AdvGridWorkbook.TAdvGridWorkbook
I suggest AdvGridWorkbook is about VCL UI Pack.

I tried to reinstall packages with the following orders with all checkbox about recompiling DCUs for Grid Bridges and FlexCel checked:

Grid Bridges


Grid Bridges

both are giving errors about wrong versions.

Need help stil, please

Hi, The order should be the second:
Grid Bridges

Grid Bridges

VCL UIPack and FlexCel are independent so order for them doesn't matter. But the third one must be grid bridges, because it depends in both FlexCel and UI Pack, so it must be compiled after both so it references the correct dcus.

Now, if you have already tried installing the bridges last, then the other cause for this error is always some older version of either VCL UI Pack or FlexCel still in the path. Search your hard disk for AdvGridWorkbook.pas (and AdvGridWorkbook.dcu) and make sure only one is available. Then reinstall the bridges (If FlexCel and UI Pack installed without issues there is no need to recompile them anymore) and the problem should be gone. I don't think I remember a single case of this error not caused by an old version installed somewhere.

Hi Adrian,

checked all dcus on my machine:

tried with the reinstallation of all of the three packages by orders on instllation as pointed in your comment as well -- no luck so far:

Is it possible for me to get previous verions of the VCL UI Pack and FlexCel back?

Thank you!

Hello Sebastian,
I also faced this problem several times after updating to newer versions. In some cases I copied the file UAdvGridExcelExport.pas to the project folder and was able to compile then.
For sure not a permanent solution, but a quick (and dirty) fix that helped me for a transitional period...

Regards, Tom

Hi Tom,

thank you very much -- you made my end of the year :slight_smile:

Coping of the UAdvGridExcelExport into the project folder helps by me!

I have also tried to add the path to the source folder with the unit UAdvGridExcelExport.pas into:

Rad Studio -> Tools -> Options -> Delphi -> Library -> Library Pathes

and placed it at a higher place.

It seems it is a working workaround too .

Thanks to all came up with the help and my warmest wishes for a happy new year.

I can get you any older version of FlexCel and I think you could get the VCL UI pack with the people on charge of the UI pack, but it won't change the problem. We see this problem all the time, and it is always an old dcu or pas somewhere. I know it can be hard to find, and I've fought with it myself on my own machines, but you can trust it is an older dcu or pas somewhere. And even if you installed the same exact version of the components, the dcus would not be compatible. You need to cleanup the machine, there is no much workaround about it.

The solution Thomas suggested can work because if you copy UAdvGridExcelExport.pas to the project folder it takes priority and it is found before the other dcus so it sidesteps the problem (the old dcus are still there, but not found), but in other way is worse, since you are having even more repeated pas and dcu files (now you also have the one you copied in the project folder).

Search also for UAdvGridExcelExport, or the other files, somewhere it is the old file causing the trouble.

Ok, I got your new email right now, and I just wanted to say that if it was fixed by putting it in a higher place in the library path, then it means that somewhere below that library path is the culprit.

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.