EXDataHttpException with message 'You do not have enough permissions to perform this action'

I created a vanilla TMS XData VCL Server Project.
Used the TMS Data Modeler to create my Aurelius Entity.
I'm using NexusDB for my database.
Executed the project.
Tried to perform a Get on one of my Table Items.
Receive the error.

I did nothing with permissions anywhere. This is a fresh project.
Database is active, the sample test functions work fine.
There is no security on the database.
Using the latest version of all TMS controls.

Have you used properly set the DefaultEntitySetPermissions property to enable the automatic CRUD endpoints?

DefaultEntitySetPermissions: TEntitySetPermissions Specifies the default permissions for all entity sets. By default no permissions are provided, which means entity publish will not be available. This is different behavior than when creating TXDataServerModule directly, since it automatically publishes all entities.


I read the documentation before I contacted you and it said:

By default, all entity sets defined in the XData model will be published by the server with full permissions.

Found Here: Document Reference

I have it working by adding the permissions manually.
Thanks Wagner!

That is true if you create the TXDataServerModule object directly.
But when using TXDataServer component, they are disabled by default.