Error after resizing

As soon as the width or height of the TWebGmap is changed, for example, by dragging the window, the composition responds very slowly and is almost unusable.

What is this problem?


I have not been able to reproduce this issue.
Does the issue also occur in the demos or only in your own application?
Can you please let me know which version of Delphi you are using so I can further investigate this?

I have the problem in my application. I also have this effect in a test project...

1. New VCL project
2. Only TWebGMaps on mainform
3. Align: = alCLient
4. Start
5. Maximize form
6. The application stops responding or very slowly

I'll try to reproduce the issue with the steps you provided.
Can you please also provide the version of Delphi you are using?

Yes, thank you. 

Rad Studio 10.2


I tried it with VCL form with the WebGmaps component. Also no resize possible, the whole
component is blocked.

I use Rad Studio 10.2.3 Tokyo.

This error did not exist yesterday, if I am right.

Maybe Google changed something in the API.

Sincerely Peter

I have been able to reproduce the issue now.
It's possible this is a temporary with the Google Maps API.

We'll have to further investigate this if the problem persists.

after some clicking on the form or the handles  or after some minutes comes a message:

If the script should be canceled?


I have same problem in FMX version. When resize, application stops.

I checked if there is a new Google Maps API-Version. But it has not been changed in the last days.
Currently it is Version 3.35. It will change mid-February.
Here the info about updates:

Quarterly updates

Once per quarter, the Maps JavaScript API team releases a new version. This happens mid-February, mid-May, mid-August, and mid-November. The next update will be mid-February. The new version will be 3.36. At that time, versions will be updated and the following changes will take place.

So something else is the culprit for all TMS components using Google Maps API not working as expected.


Choosing the weekly channel

Maybe the weekly channel made some changes!?

For most applications, we recommend the weekly channel. This is the most current and up-to-date version and contains the latest bug fixes and performance improvements. You can specify the weekly channel by loading the Maps JavaScript API with the following script tag:

Currently, the weekly channel is version 3.35. This version is updated weekly with new features, bug fixes, and performance improvements.

Which version of JavaScript are you using?

Mine is 1.7


We've been experiencing the very same issue on our end since yesterday, no change whatsoever on our end. Worked fine the day before and broken as of yesterday. 

I am using a UHD monitor at High DPI. 

Bart, I also have a test application, I'll email it to you. 

We also started seeing the reported issue a couple of days ago with no code changes from our side.
We have no control over this as this is most likely an issue with the Google Maps API,
We'll have to investigate if there is a possible workaround available.

After further investigation we have strong indications that this issue is related to a recent Windows update.

The issue can also be reproduced in the latest version of IE included with windows, while Chrome seems unaffected.
Note that both TWebGMaps and TTMSFMXWebGMaps components rely on the TWebBrowser control which in turn relies on the Windows IE engine.
At this time we are not aware of any workaround so we'll have continue investigating.

Windows updates were installed on a windows 7 computer on 9th of January, but not 15th of January, when the problems started.

There have been security updates KB4480970, windows update KB4480063, security updates KB4483187, or Microsoft Frame Network KB4480055 on the 9th,

On the 17th another  Microsoft Frame Network KB4480096.

And what should be the culprit?

As informed, the problem can be reproduced in a standalone Internet Explorer, so it is unrelated to our code in the Windows WebGMaps components.

It appears that when there are a lot of simultaneous tile requests from the Google maps server from Internet Explorer, it doesn't return tiles anymore, requests resulting in timeouts.
It appears to be a problem between Internet Explorer and the Google Maps tile server. We thought that the Windows update (which does affect Internet Explorer) was the logical answer to what changed. I'm afraid that only contacting Microsoft and Google can reveal what is really happening here.

I could not reproduce it with Internet Explorer on windows 7 machine.

How did you do it?

I also couldn't reproduce it with Internet Explorer

Are you effectively testing the Google Maps JavaScript API? This is different from simply navigating to!