Dropbox demo - download not working

Demo download is not working on dropbox.

Permissions are all set in dropbox app console...


We are not aware of any issues with file download for DropBox in TMS FNC Cloud Pack.

Can you please provide the following info so I can further investigate this?

  • Delphi version you are using
  • Target platform (Windows, iOS, Android, ...)
  • Please describe exactly what is going wrong during the download process.
  • Does the issue happen for a specific file or for all files?

It doesn't work for me either:

  • Rad Studio 12 Athens Pro.
  • Windows 11 Pro
  • Won't download any file with .nx1 ext. I don't have any other types stored in Dropbox.

Further info. Following downloads from Dropbox, there are shortcuts in the c:\users<username>\Recent folder pointing to the correct download folder, but there are no target files in that folder. Strange.

I suspect the problem is the DropboxURL setting I'm Using:

DropBoxURL := 'http://localhost:8000';

Entering 'http://localhost:8000' in my Edge browser gives a 'can't reach this page' error. I can't see where to enter the redirect URI in my basic Dropbox a/c as shown in your TMS Cloud / Mapping controls doc. Please advise.

Never mind, I've figured it out.

Hmmm.. I thought I had it figured out but I still cannot download a file from Dropbox using either of the following Dropbox URLs:

DropBoxURL := 'http://localhost:8000';
DropBoxURL := ''

Both redirect URIs are set in my Dropbox a/c. I'm sure downloading worked ok in D11.3.

I have not been able to reproduce an issue with file downloads using DropBox in Delphi 12.
It is unlikely the issue is related to the callback URL as it is only used during authentication.
If authentication is working, the url is valid.

Have you tried downloading different types of files or to different folders?
You can enable logging (set Logging to True) and inspect the generated log file to see if any errors have occurred.

If the issue persists, please provide the log file so I can further investigate this.

Thanks Bart. I can't see where to switch logging on, but using the following procedure, I get the following results when trying to download .nx1 (NexusDB) and .ini files to two separate folders:

procedure TFormFNCCloudStorage.TMSFNCCloudStorageServices1DownloadFile(
Sender: TObject; const ARequestResult: TTMSFNCCloudBaseRequestResult);

ARequestResult.responsecode = 409
ARequestResult.totalbytes = 95
ARequestResult.resultstring = '{"error_summary": "path/not_found/", "error": {".tag": "path", "path": {".tag": "not_found"}}}'

I'll provide a log file if you can advise how to set logging to true. Happy New Year.

  • I found an issue in the DropBox download functionality that can cause the problem you described when downloading from subfolders.
    This issue has now been fixed and the update will be available with the next release of TMS FNC Cloud Pack.

  • How to enable logging:
    TMSFNCCloudStorageServices1.Storage.Logging := True;
    TMSFNCCloudStorageServices1.Storage.LogFilename := 'c:\filename.log';

Thanks Bart. Look forward to the update.

Thanks Bart. Downloads from both DropBox and OneDrive work ok now with the latest TMS FNC Cloud Pack.

Happy to help!

Thanks for informing the issue was resolved.