AdvGridDropDown Selection does not work

Since we did install the new VCL UI Pack at June, 16 2020 the AdvGridDropDown doesnt work as usual.

Whatever i type the grid drops down and the first row is marked.
When i type the letter again, the first column in the drop down grid gets black.

I need quick help, because the component is in use and does not work any longer, so my customers are angry.

I retested this with demo 83 and TMS VCL UI Pack v10.3.5.0 and I cannot reproduce this.

I use TMS VCL UI Pack v10.3.2.
How can I download asg83. I only see text, but there is no executeable sample?

All demos are included in the install. See Documents\tmssoftware\TMS VCL UI Pack\Demos

All demos, except from asg83.
Also on your link there is no possibility to load it down.

I can absolutely not see any reason why you would not have demo 83, it is included in the distribution just like any other of the 93 TAdvStringGrid demos.
I have attached it here and I suggest to test it with the latest TMS VCL UI Pack release (54.9 KB)

I currently installed the latest Version v10.3.5.0 | Thursday, July 30, 2020 i found on your page.
Then i compiled demo 83.
After the programm started, I see a blank drop down.
I typed "mercedes" in the field, nothing happens.
I opened the Dropdown by clicking at the arrow, the dropdown opens and the firs row (PORSCHE) is marked.
I put my cursor back to the input field and tried to type "ferrari", nothing happens.
I opened the Dropdown again and the following happend.
I went back to the input field.
when I now pressed the backspace key the following is in my input field.

I think this is not a right behavior.
What can I do.

Do you have any new infos about my problem?

We have reopened the case and made an improved to both TAdvGridDropDown and the demo itself.
The next update will have these improvements.

I installed the latest version, but my problem isn't gone.

The failure happend when I have for example some values beginning with "a", the next values beginning with "b". I choose the first value with "b", selected it with "Return" then the last value with "a" is shown in the text field.

So I tried to find the failure. I think there is a bug in Unit AdvCustomGridDropDown.pas.
The variable "FSelRow" in procedure DoHideDropDown doesn't have a proper value at every time.
So i set FSelRow:= FAdvColGridRow at the beginning and so I get the right result on selecting a value.
Maybe you can check this.
CustomAdvGridDropDown.pdf (6.0 KB)

I could not reproduce an issue with the demo.
The code change you applied should not have side effects. (although it needs to be checked is FAdvColGrid is assigned), so we added it.
But we'd like to know how exactly the problem can be reproduced.