XData: Error compiling the Android platform in debug mode

Hello, I recently debugged an Android App project and it is only showing an error during debug.

C:\Projetos\Componentes\tmssoftware\TMS XData\packages\d12.\Android\Debug\XData.Client.dcu' - Expected version: 36.0, Android(ARM64) Found version: 36.0, Android(ARM)

This looks like a Delphi bug or mixing folder issues.
Have you manually changed your library path or project source path?
Please try to uninstall everything and reinstall again. If possible, use TMS Smart Setup.

I recently updated to Delphi 12, I have already uninstalled and installed tms twice. I didn't try to modify it manually.
I will download and test TMS Smart Setup

I used TMS Smart Setup but it gave errors in all these packages.


  1. Provide the full log file of the installation.
  2. Provide your full PATH environment variable content
  3. Provide the file names present in the folder C:\tms.tmssetup\build\bpl\win32 folder

env_variable.txt (2.5 KB)

logs.zip (96.1 KB)

Everything seems to be correct. There are no errors in log, the environment variable is correctly set, the files are there in the folder.

I don't know why Delphi is not being able to load it.
What do you have when you open Component | Install Packages menu? Are the packages there, are they checked, are you able to check them?

Also, what do you have in PATH override variable configuration? In Delphi Tools | Options, IDE Options, Environment Variables?

env_variable.txt (2.5 KB)
override_variable.txt (2.6 KB)

I tested TMS Smart Setup a lot and it didn't work. I went back to using TMSSubscriptionManager2 and was able to run it in debug mode on the Android platform again. But I uninstalled it and used TMS Smart Setup and the packages didn't install like on previous printers, so I started using TMSSubscriptionManager2 again and everything is normal but I intend to use TMS Smart Setup.

The problem is with your PATH variable override. It doesn't have the $(PATH) macro there.
That is actually a problem with ACBr installer, which wrongly removed the $PATH macro and replace it with the existing PATH variable content.
When Smart Setup modifies the PATH variable, Delphi doesn't detect it.
You should fix the PATH variable override by re-adding the $(PATH) macro to it. We have notified the ACBr team about this issue.

Sorry, I understand that it is the ACBr installer that is modifying. But how should I put it?

Just put this value:


I put $(PATH) at the end and enabled the packages manually and it worked, Thank you.

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.