Webupdate: cannot find libssh2.dll


Misschien is dit geen "TMS-probleem" , maar wellicht kan iemand mij helpen met het volgende:
Ik heb de WebUpdate over sFTP nu bij een honderdtal klanten geïnstalleerd, en dit gaat vrijwel altijd goed. Werkt perfect.
Echter, nu heb ik een klant waarbij de melding komt "cannot find libssh2.dll" . De dll staat in de aplicatie-map (zoals altijd). Het is gewoon een Windows10 omgeving, en ook "run as administrator" helpt niet.
Wat zou de oorzaak kunnen zijn ?

Iedere hint is meer dan welkom,

met vriendelijke groeten,

Dirk Janssens.

I suggest to start checking what security tools are running and possibly interfering.
Try to disable such security and/or antivirus tool and see if it helps.

De klant heeft 2 PC's, waarbij er één problemen geeft.
De klant geeft aan dat op beide PC's dezelfde anti-virus software draait, en dat het ook niet uit maakt of deze actief is of niet. Op één PC draait de software zonder problemen, de andere geeft aan dat de dll niet gevonden kan worden....

Een verschil dat ik wel zie, is dat de PC met de problemen Windows10 Pro is, de andere is Windows10 Home. Zou dat misschien nog ergens op kunnen wijzen ?

Does it help to put the app in a totally different folder where limited privileges could not affect it?

Ik zal het proberen. Zou een submap in "Mijn documenten" een goed alternatief zijn ?
(Op dit moment staat het in c:\MijnApplicatie\ )

Zojuist de map naar "mijn documenten" gekopieerd. De firewall, die ik weer aan had gezet, vraagt dan of de applicatie toegestaan moet worden, ik klik op ja. Het heeft allemaal geen effect. Zodra ik check voor updates, krijg ik de melding "dll niet gevonden".
Ik weet niet meer waar ik het nog moet zoeken ...

You could try to put it in C:\Windows\System32
Other than this, I have no more ideas.

Do you mean the dll, or the appliciation ?
I already had a copy of the dll in the system32 directory, without any effect

I'm sorry but I really have no idea what is happening on this particular machine.

Hi Bruno.

//I'm sorry but I really have no idea what is happening on this particular machine.
No problem, it is a strange problem, and aparently hard to figure out...

I went on doing some research and have the following:
The system adminstrator executed the same function (same program) on both machines.
The only difference is the account.
He gets different errors, on both machines (!)
Maybe they are helpfull in solving the problem ?

Furthermore : the errormessage I get, I recently had on another machine where the MSVC++ Redistributable was missing. After copying the MSVCR110.dll it worked fine.
Howver, this is not the problem on this particular machine. But, are there maybe some other specific dependencies other then the libsh2.dll for the Webupdate to function ?

kind regards,

Dirk Janssens.

This error appears to be an error while an FTP action is happening. Can this? If so, is this user using a specific FTP server others are not using?

All I do is call
up.NewVersionAvailable ( up is a TWebUpdate component )

I have assigned a codesite sendmsg to every eventhandler, and this is what I found:
The event On status, with message "Connect to host" is the last one without error.

If there is no error, the next lines would be :

  • upConvertPrefix

So it seems the error occurs after the "Connect to host", and before the OnConvertPrefix.

for completeness :

with error :

without error :

Can you try to set WebUpdate.FTPPassive = true?

I tried it, unfortunatly, this has no effect...

For completeness, these are the properties of the TWebUpdate-component before calling "NewVersionsAvailable"

Do you have an FTP test account + sample source project with which we can reproduce this?

This is difficult, because on most machines it does work ..
I can send you a project however, and maybe you can test it on multiple machines ?

I'm not sure this makes much sense if we do not have the code.
Can you at least add something like Eurekalog or madExcept to get more info on the exact place in the code where an error occurs?
This error report is also getting very confusing. First it starts with a DLL that couldn't be found and now it seems to center around access to an FTP server?
I propose to follow up this discussion via direct email and with sufficiently detailed information and clear description of the problem and preferably with code + account with which the problem can be reproduced. I cannot see this is anything in our code but most likely something broken in the OS on one specific machine.