Webupdate SFTP url format

Hello ,

I am trying to configure the WebUpdate with SFTP.
With FTP it works,
but with SFTP, calling NewVersionAvailable,
I get Access Violation right after "Connect to host".

I tried the following settings :

host := 'ssh.strato.com'
FTPDirectory := '/.cm4all/mediadb/Downloads/Updates'

url := 'sftp://strato.com/.cm4all/mediadb/Downloads/Updates/Strato_test.INF'

( also tried
url :='Strato_test.INF'
url := http://ssh.strato.com/.cm4all/mediadb/Downloads/Updates/Strato_test.INF (like the updatebuilder generates)

Update Builder uploads the files to the right place.
I also converted the *.inf file to ANSI

relevant the update-setings :


any help is very welcome !

kind regards,

Dirk Janssens.

There was a known issue for the NewVersionAvailable function in combination with sFTP that was internally already fixed and this fix is scheduled to be included in the upcoming release v10.4.4.0

Thank you Bruno,

Can you tell maybe when this update is expected ?

kind regards,

Dirk Janssens.

It is scheduled for today.

That's good to hear.
Any chance there will be an "ANSI -compatible"UpdateBuilder available ?

That was answered in the other thread you created.

I downloaded the update, but the problem persists ...
I stil get Access Violation when calling NewVersionAvailable
doUpdate does not work either...

Please send the log file via support email.

zie bijlage


Dirk Janssens.

logStrato.txt (247 Bytes)

All I see is
09-10-2020 16:22:47 : [918] Checking for Internet connection (Status:3) (Error:0)
09-10-2020 16:22:47 : [921] Found open Internet connection (Status:3) (Error:0)
09-10-2020 16:22:47 : [923] Connect to host : ssh.strato.com (Status:3) (Error:0)

so, it seems it could not connect.

Do you put the DLL's libeay32.dll / libssh2.dll in your EXE folder so it can find these?

Hallo Bruno,

Nee, dat had ik niet gedaan.

Ik zie dat de libssh2 door TMS wordt meegeleverd.

Helaas, als ik beide dll’s naar de exe-map kopieer heeft dat geen effect …


Dirk Janssens.

Verzonden vanuit Mail voor Windows 10

Oeps, sorry for switching to Dutch, I thought the reply was by email (not in the support group).
Anyway, copying the dll's did not help.
Has anybody configured SFTP succesfully ?
Does it depend maybe on the version of libssh2.dll ?


Dirk Janssens

I propose you create a test account on your sftp server , provide the details via direct email and we will test it from here.

1 Like