Help with WebUpdate SFTP configuration

I have used the updater before on a network, but have little experience with ftp.

I had no problem uploading from Update Builder, or connecting with FileZilla and downloading the files, but cannot get the TWebUpdate component configured for a valid connection.

Using DreamHost and SFTP

any help would be appreciated.


vResources.txt (357 Bytes) WUPDATE.LOG (9.1 KB) WUPDATE.LOG (9.1 KB)

The error I see in the log is:

15/04/2021 08:33:32 : [923] Connect to host : s (Status:3) (Error:0)
15/04/2021 08:33:32 : [980] Cannot connect to SFTP host : No such host is known (Status:3) (Error:5)

I suspect you need to set HOST to: and set WebUpdate.UpdateType = sftpUpdate

I have FTPDirectory set: /home/vrUpdate/Update
Host :
and updateType sftpUpdate

I have tried every combination of http:// https:// sftp:// ftp with the above settings I still get
Update failed with external exception C06D007E

I suspect the culprit to be the URL.

Any ideas?


Any possibility you can setup a test account on this server so we can test from here?
If so, share such details in PM.

Absolutely, where should I send the info?

Best to send this by email directly to support.


We could reproduce the issue here and it was resolved by making sure that the 32-bit version of MSVCR110.dll is available for the application to see.
You can try to install the 32-bit version of Visual C++ Redistributable for Visual Studio 2012 Update 4:
This installer will put the DLL in your SysWOW64 folder and the connection should succeed after that. If you still run into issues, let us know.


Did you get the app to update? If so, what were the FTPDirectory, Host and URL settings?

I still get the same error. I already had the Redistributable, but ran the update anyway.

I attached the log file.

BTW I currently run the update on a different project, on my local network as FileUpdate with no problems.

WUPDATE.LOG (257 Bytes)

The main question is, do you still see the exception you reported earlier after the Visual C++ Redistributable update?
Update failed with external exception C06D007E

We did some further investigation and detected another issue when connecting to subfolders which prevents your application from updating. We applied a fix that will be part of the next update.
Settings as follow:

FTPDirectory := '/home/tms_Update/Update';
Host := '';
URL := 'TestTMSUpdate.INF';

Until the next update you can either put your update files temporarily to the root SFTP folder or if this matter is urgent, you can contact us for an incremental source update.


Yes I still get the same exception.
Unfortunately, '/home/tms_Update' is as close to the root as DreamHost allows for users, and this still produces the exception.

My settings:
FTPDirectory: 'home/tms_Update'
URL: TestTMSUpdate.INF
also tried
URL: s

I can wait for the update, however if you would like to send an incremental update to be sure it works on another machine that would be fine also.

The exception you see should be unrelated to the connection. It's most likely an issue with a DLL, so you can try the following:

  1. Make sure that libssh2.dll, libeay32.dll and ssleay32.dll are next to the executable or are available in a system path.
  2. In the libssh2_sftp.pas unit search for the line you see below and temporarily comment out the delayed keyword to disable the delayed loading of the libssh2.dll:
function libssh2_sftp_init; external libssh2_name{$ifdef allow_delayed} delayed{$endif};

This should then throw a different exception that will point to the right direction.


I had to copy the dll's into the exe directory even though they are in the System and User path or I got a message that they could not be found.

Now I get an error with unrecognizable text, you can see this in the log file


If you read the log, you'll see that it finds the INF file but not the CAB. This is due to the issue I mentioned earlier with the subfolders and will be resolved with the next update.

We did not experience this here. Was it available in the PATH environment variable?