Will this control be included in the future? It is used in the chat demo but I cannot find it. I have not been able to get the WebSocketClient to work with any of the open source WebSocketServers and most of them are not being maintained.

The unit with this code WEBLib.WebSocketServer.pas is included in the install subfolder Component Library Source

I find the WebSocketClient there but not the WebSocketServer.

I cannot see a reason that WEBLib.WebSocketServer.pas is not under the folder "Component Library Source".
Did you check in this folder?

I have a "Core Library" folder but no "Component Library Source" folder. I uninstalled the WebCore, downloaded it again and reinstalled it just to be sure.

I suppose you use the trial version then? In the full version this folder with full source code is available.

I did have the trial c=version installed but this is the registered version from MyProducts page. Yesterday I uninstalled the WebCode and XData and FNC components, went through the registry and deleted any Web Code related stuff, downloaded them again and reinstalled with the same result. I will try to install on another computer but no luck on my laptop,

The fileWEBLib.WebSocketServer.pas is in the registered version of TMS WEB Core in the folder Component Library Source under the install folder. 

I did a clean install on a different computer and here is the directory for Tokyo:

C:\Users\mdunc\Documents\tmssoftware\TMS WEB Core RSXE11</div>
Compiler                                        <DIR>          8/1/2018 10:10:20
Config                                          <DIR>          8/1/2018 10:10:19
Core Source                                     <DIR>          8/1/2018 10:10:19
Doc                                             <DIR>          8/1/2018 10:10:20
jqwidgets                                       <DIR>          8/1/2018 10:10:18
TMSWebRunner                                    <DIR>          8/1/2018 10:10:06
TMSWebServer                                    <DIR>          8/1/2018 10:10:06
Win32                                           <DIR>          8/1/2018 10:10:19
TMS.WEB.Controls.res                                  174,092  7/25/2018 11:45:22
TMSWEBCore.txt                                          5,233  7/31/2018 16:36:04
unins000.dat                                          282,381  8/1/2018 10:10:21
unins000.exe                                          821,128  8/1/2018 10:08:38
unins000.msg                                           11,401  8/1/2018 10:10:21
WEB.ico                                               105,890  1/23/2018 14:11:24
6 files, 8 folders                                  1,400,125 bytes
C:\Users\mdunc\Documents\tmssoftware\TMS WEB Core RSXE11\Compiler</div>
libpas2js.dll                                       6,673,341  7/30/2018 12:14:32
libpas2js_64bit.dll                                 7,847,743  7/30/2018 12:14:32
pas2js.exe                                          1,441,280  7/30/2018 12:14:32
version.txt                                                 5  7/30/2018 12:14:32
4 files, 0 folders                                 15,962,369 bytes

I don't need it and it doesn't matter me - but just to let you know - WEBLib.WebSocketServer.pas is in none of the TMS WebCore Installation directories here also.
It's WebCore Full and Tokyo.

Regards, Tom
I just opened the FNC-Chat demo delivered with WebCore. 
Following the Project-Source-File of the server-Service, WEBLib.WebSocketServer.pas should be in "..\Websockets\" of the demo-source - but is not...

We have seen an issue in the installer. We will repair this. Sorry for the confusion.

I am still not seeing a WebSocketServer component. Will that be coming soon? I could really use it.

Contact us by email and we'll provide it. 
The installer will be revised next week to include it automatically.