Unit TMSLogging can't be found for Linux64 Target

I'm trying to use TMS Logging for an apache module on Linux. I can't add the unit TMSLogging. TMSLogging can't be found. The path C:\Users\andre\Documents\tmssoftware\TMS Logging\packages\dsydney.\Linux64\Release is added to the Library Paths. However, the path contains no TMSLogging.dcu file (same applies to the debug unit path). There are only these files: TMSLogging.dcp, TMSLogging.imp.o and TMSLogging.o.

The IDE plugin only adds TMSLoggingUtils to the uses clause. However, that doesn't create the TMSLogger instance.

I tried to rebuild the TMS Logging packages. That did not change anything. What am I missing here?

AFAIK TMS Logging do not support Linux yet. There are at least 2 feature requests for that you can vote for.


TMS Logging does support Linux in its latest version 2.1, released on June, 2020. Please check you have the latest one:


1 Like

I have 2.1 installed

Real unit names are Vcl.Logging and Fmx.Logging, which are used in VCL and FMX applications. In Linux you must use only TMSLoggingCore.

With all due respect, maybe enlighting a bit more than mentioning that Vcl.TMSLogging and Fmx.TMSLogging is not available in Linux64 (which is quite obvious) would help getting this to work in Linux64.

I can see that in VCL.TMSLogging TMSLogger is instantiated by calling TMSLoggingSingleton.GetInstance. What Type am I supposed to use for TMSLogger in Linux64?

I'm not happy with how this is documented. Maybe I'm just a bit shortminded, please help in getting this to work.

Got it figured out now. TMSLoggingCore creates TMSLogger. I have no clue why yesterday, Delphi complained about TMSLogger not being defined. That was confusing. Anyway, it is solved now.

1 Like

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.