TWebSyntaxMemo problem

I created a new PWA app and dropped a TWebSyntaxMemo on it, set the mode to pascal, then tried to run it up.

It compiles and launches the browser, but I get this in the browser

Uncaught ReferenceError: ace is not defined | ReferenceError: ace is not defined at Object.InitializeKeyWords (http://localhost:8000/Project5/Project5.js:40532:27) at Object.EndUpdate (http://localhost:8000/Project5/Project5.js:40490:12) at Object.AfterLoadDFMValues (http://localhost:8000/Project5/Project5.js:13093:12) at Object.LoadDFMValues (http://localhost:8000/Project5/Project5.js:40723:29) at Object.DoCreate (http://localhost:8000/Project5/Project5.js:37787:12) at Object.Create$5 (http://localhost:8000/Project5/Project5.js:38247:12) at Object.c.$create (http://localhost:8000/Project5/Project5.js:328:19) at DoStatusCreate (http://localhost:8000/Project5/Project5.js:39441:32) at XMLHttpRequest.cb (http://localhost:8000/Project5/Project5.js:256:21)
at http://localhost:8000/Project5/Project5.js [259:48]

Do I need to copy the ace code into a folder or should this have happened by itself ?

This is on XE 10.4.2 with TMS components that were updated a few days ago.

Could be that the javascript library isn't being loaded? In the project pane, right-click on the main project and select "Manage Javascript Libraries..." from the menu. Make sure ace is enabled in the list. This basically adds a line to the main project.html file to load the ace js from a CDN.

That was it Andrew. Thanks for the help.

Glad it worked! I've been using the ace editor in my project and it is a bit finicky, so be sure to post any other questions you might have. I'm in no way part of any official support team here, just nice to see a question I knew the answer to!

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.