TMS Sparkle Error in Reservation

I've upgrade RIo to 10.2.3
I've install the last version TMS Core - Sparkle - Ayrelius and XData

When i tried to vreate TMS Sparkle reservation i0ve an error.
The action is correct in previous version (Rio 10.2.2 and TMS product)


HTTP Server API Error
Access Denied

The problem presents itself with RIO10.3.2. Installed TMS Core / Aurelius / Sparkle / XDATA if I use TMSHttpConfig and add an entry I get HTTP Server API Error - Access Denied

Are you running TMSHttpConfig utility with administrator privileges?

Problem solved.

I've Administrator Privileges in my PC.
When run TMSHTTPConfig in windows have not problem, if i start program in IDE i have a problem because IDE not start as Administrator.

I have a similar error.
I start TMSHTTPconfig with admin rights, choose SSL - Add
and "Select Certificate"
I take my own certificate made with TMS X509v3 Certificate Generator
By clicking "OK" an error appears:

HTTP Server API Error.
Eine angegebene Anmeldesitzung ist nicht vorhanden. Sie 
wurde gegebenenfalls bereits beendet.

I don't know the error message in english

Thomas, your problem it's a different one, that's an invalid certificate.

Is there any help on how to generate a certificate? What can I do wrong? It's only for test on my local computer.

Without a real domain, you will only get "fake" certificates (self-signed), so I'm not sure exactly what you would like to test? 

In any way you can try to create the self-signed certificates. Here is an example:

Is not it true that we need a certificate to test https? (Google translator)
We want to test server and client modules on different devices. We have firmly defined https in our modules. On our Cloudserver, we have Let's Encrypt installed and it works fine.

Can we test on local computer without certificate? I thought, no.

It's true, but what exactly you want to test? In Sparkle, for example, HTTPS connection is transparent. If it works fine in your server with Let's Encrypt, then isn't it tested and confirmed to work?

Of course. But we are at the beginning of our development and want to test in the short way on the local development computer. At the first time, we took http, but we want to get used to using only https. (e.g. on apple http doesn't work without changing system settings).

Ok, we need a certificate. Actually we use a certificate on my computer from our financial accounting software.
Does that mean that we can NOT use the TMX X509v3 Certificate Generator?

I'm not sure what do you mean by TMX X509v3 Certificate Generator?

One thing you should be aware is that this is actually out of Sparkle scope. TMS Sparkle and XData will work smoothly with whatever you have set there, because that certificate configuration is at Windows level. The initial error you got was returned by Windows, not Sparkle. I just pointed out that such error is usually caused by a bad or misconfigured certificate.

Using self-signed certificate is possible and you can use it with Sparkle, using techniques like the ones describe in the link I sent you. But I'm not sure how it will help working from iOS, as it will probably reject it anyway because iOS won't be able to validate the root certificate. 


But, the TMS X509v3 Certificate Generator is from TMS ;-)
That is why I asked

There seems to be indeed an issue with the specific Certificate Generator tool in the web site. One thing you can do is install TMS Cryptography Pack, there you have a similar tool, but it's updated and the issue is not present. Or you can use any other tool that generates certificates, of course.

Thank you. I will try to use the Crypto Pack.