TMS Chart android static libs not found

When I attempt to build TMSChart components into android (XE8 C++) I get a missing library message:

Unable to find static library: libTMSFMXChartPkgDXE8.a

Searching the install directory I see that this library does not appear to exist, but the object files are there:

C:\Users\nzg8636\Documents\tmssoftware\TMS Charts for FireMonkey\BuilderXE8\Android\Debug\TMSFMXChartPkgDXE8.hpp

C:\Users\nzg8636\Documents\tmssoftware\TMS Charts for FireMonkey\BuilderXE8\Android\Debug\TMSFMXChartPkgDXE8.o

Is this correct? Did something fail to compile in the install? Did I forget to do something in the install?

Even with these pop ups it does compile and load on the device (Nexus 7 2013), but the charts are incredibly sluggish to respond to touch events, which is possibly a different issue.

For C++Builder you need to recompile your packages with the target platform set to Android.

Thank you Nancy,

Do you mean I need to compile the libraries beyond what the installer does?

If so is there a pre-made project for doing this in C++? All of the top level projects and examples appear to be Delphi projects, which I cannot open in C++.

Am I missing something?

Figured out I can do this from the command line with:

call "%ProgramFiles%\Embarcadero\Studio\16.0\bin\rsvars.bat

msbuild TMSFMXChartPkgDXE8.dproj

Which does compile but I still don't get the android libraries. Looking into the Dephi project it appears that it doesn't have an android target, XML pasted below:


               <Platform value="iOSDevice">False</Platform>

               <Platform value="iOSSimulator">False</Platform>

               <Platform value="OSX32">True</Platform>

               <Platform value="Win32">True</Platform>

               <Platform value="Win64">True</Platform>


Is there an easy way to add this? Is there an updated build file for this?


The latest installer for the TMS FMX Charts should automatically compile for C++Builder XE8. Can you perhaps try to uninstall and reinstall from scratch? It could also be a missing path in your IDE, possibly because the IDE isn't correctly configured. If the problem persists you might need to reinstall the IDE. You could also try to uncheck runtime packages for your C++Builder package.

Kind Regards, 

I tried reinstalling the IDE but got the same results. Are there any other options I could try?

Right now I'm just clicking through all the default configurations, I'm using Windows 7 64 bit computer for this and installing on the local drive in the default location, nothing fancy.

I attempted to uncheck runtime packages but this does not appear to be an option for the android target. If I go to project->options->packages->runtime packages there is an option for "link with runtime packages", but if I set it to all platforms the tooltip says

"link with runtime packages, 32-bit Windows, OS X, 64-bit Windows platform only"

If I set it to the android option this checkbox option does not appear at all.

the lib file should be located under Users\Public\Documents\Embarcadero\Studio\16.0\Bpl\Android. or C:\Users\Public\Documents\Embarcadero\Studio\16.0\DCP\Android one of the subfolders. If this is the case, you will need to make sure the library paths for Android C++Builder points to the path where the lib file is located. We have experienced issues with installing our components for XE8 C++Builder. It could be possible that this issue is resolved in update 1.

Kind Regards,