Library not found

I just installed TMSFMXPACKSETUPREG.ZIP fresh into Rad Studio XE8 and when I try to compile for iOS, I get this error: [ld Error] ld: library not found for -lTMSFMXPackPkgDXE8

Compile for Android works fine and iOS had been working prior to the FMX-Pack install.

I also installed the ChromiumFMX component and that is also working on Android.
What can I do to track this down?


Please check your library path for iOS under Tools, Options, Delphi, Library
It should include the folder where the sources of TMS Pack for FireMonkey are installed.

I'm actually using C++Builder, but the path is the same under both

Delphi Options->Library->Library Path
C:\Users\John\Documents\tmssoftware\TMS Pack for FireMonkey\DelphiXE8\iOSDevice32\Debug
C++Options->Paths and Directories-> Library path
C:\Users\John\Documents\tmssoftware\TMS Pack for FireMonkey\DelphiXE8\iOSDevice32\Debug
I found these two files in that directory (and lots of other files):


Can you send us the log file that is generated under my documents and formatted with the version number and the product name?

Kind Regards, 

We have further investigated this here and there is an issue with the output path of default packages or an issue with the system path configuration in XE8.

This is an issue in C++Builder only and will hopefully be fixed in XE8 update 1. We will investigate this further, a temporary solution would be to copy the libTMSFMXPackPkgDXE8.a and TMSFMXPackPkgDXE8.dcp






Hi Peter,
I installed TMSFMXPackPkgDXE9 on C++ builder XE10, and I faced the same issue for IOS.
The workaround worked for me, but please correct the problem for other users



We are currently investigating to workaround this in our installer. The next version that will be released should fix the issue.

Kind Regards, 

I got this problem now.

[ld Error] ld: library not found for -lTMSFMXPackPkgDXE9

It is ok for me to run my app on ios 32 devices under debug mode. Then I have to build for apple store using ios 64 release build. That is the time I got this problem. I use CB10, latest tmsfmxpack, osx 10.11, xcode 7.2 and iphone 4 with IOS 9.3.
I checked the file "libTMSFMXPackPkgDXE9.a" in path c:\Users\Public\Documents\Embarcadero\Studio\17.0\DCP\iOSDevice64\Debug\ and c:\Users\Public\Documents\Embarcadero\Studio\17.0\DCP\iOSDevice64. Then I added both paths to the include and library paths. I still get this problem.

The workaround is not working for me as both folders have the same files.

Any idea on how to solve this problem?




We haven't experienced issues linking against iOS 64 bit, does re-installing fix the issue?