I just tried to rebuild the scripter with the THEMED_IDE option enables, but TIDEEngine does not seem to work with the TAdvOfficeTabSet.

First I try to enable the {$DEFINE THEMED_IDE} in ASCRIPT.INC, but then it does not seem to be reckognised by the compiler, so I try to set the definition in the compiler option.  It then seems to be compiled in and the TAdvOfficeTabSet was accepted by t the TIDEEngine.  Still the script files are not shown in the tabs.  

Any idea?

Lars Magne Endresen 

How are you trying to use the TAdvOfficeTabSet? It's support as the tab control which holds the script files. it's not supported as the tab which toggles between "code" and "form" mode of each script file.

I try to use it as a tab control that holds the script files, and I have connected it to the TabControl property of the IDEEngine.

Lars Magne 

I have now installed a fresh Delphi XE3 and the last version of Component Studio and TMS Scripter.  Still I have problems to get the Scripter to work with THEMED_IDE.

I have remove the dot from {.$DEFINE THEMED_IDE} in ASCRIPT.INC and rebuildt and reinstalled all tmsscripter_xe3 packages.  The strange thing is that if I place some buggy code inside the {$IFDEF THEMED_IDE} in for examle IDEMain, it does not compile the code inside {$IFDEF THEMED_IDE} .  But if I insert the definition in the Conditional defines in the package options - it accept the definition and compile the THEMED_IDE code.  Still it does not work when I use the package in my project.

Can someone tell me the exact way to enable the THEMED_IDE in the Scripter.
Lars Magne Endresen
Embicon AS

Hi Lars, maybe what is causing confusion is that there is an ASCRIPT.INC file in source directory, and another one in source\designer directory. You must update both of them. Let me know if this solves it.

Thanks Wagner,

Now the THEMED_IDE works fine.  

But now I have got a RUNTIME error 'Cannot find form file "Unit2.sfm".' even if the file exists in the project directory (BasePath). Any idea?

You mean this error happens with THEMED_IDE enable but does not with it disabled?

Are you just running IDEPro demo?

No, this problem has been for a while but it seems to be worse after I install XE3.

I run it under my own IDE with the IDEEngine on the main form linked to a IDEDesignControl, IDEInspector, IDEComponentComboBox1, Scripter, IDEPaletteButtons, IDEWatchListView and a IDEMemo.
Then I just set the basepath and run Engine.OpenProject(MyProjectname).

Well, then it's probably something with your IDE, or at least I can't see it happen in the default IDE Pro. If you are able to build a compilable project that reproduces the problem, send it to me so I will try to fix it.

Thanks, Wagner,

I have now used some code from the fIDEEditor and now it seems to work.
By the way this is a superb tool, you have done a great job here.

Lars Magne Endresen