testing postgres 16 rc 1

Since I'm testing postgres 16 rc 1 I am not able to use Database reverse engineering anymore.

I'm using DataModeler 3.13 with these x86 libraries: (older ones, because there are no libraries for 16 rc 1)

  • libcrypto-1_1.dll Version
  • libpq.dll Version
  • libssl-1_1.dll Version

I got the same error as in postgres 11.1

DataModeler is raising this Warning while trying to Load from database:
TMS Data Modeler detected you are connecting to a database server whose version is older than the selected one (PostgreSQL 11). Reverse engineering may not work properly. Do you want to proceed?

Looks like it is not able to get the current version of postgres, so DataModeler executes old SQL?

I cannot reproduce this. I tested it here again, and I'm able to connect to Postgres 16 database with Data Modeler normally, and retrieve data from an existing database.

Can you maybe provide more steps to reproduce, or maybe test your environment in different scenarios? Are you able to connect to the database using FireDAC?

I could connect to the database using FireDAC.

My application using Aurelius and FireDAC is working fine with this.
It is also working with the same x86 libraries...

Are you able to import the database structure directly via TAureliusConnection?
Also, Postgres 16 is released. We tested with it, not rc1. Have you tried it?

We just upgraded to Postgres V16 and that is working fine.

So maybe there is something with your version-detection combined with rc1...

But now I'm able to work with DataModeler again

How could I do that in DataModeler?

That's not in Data Modeler, but in TAureliusConnection component, at design-time from Delphi IDE. It's explained here:


But anyway, it's good that you solved it, maybe it was a minor issue in rc1.


that's what I tried to tell you here

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.