Good morning, i have a problem, not so serius, with the grid.

SO : Windows 10

Compiler : Delphi Seattle

DB : Firbird

Library : FireDac

Grid : TDBAdvGrid (last version), options all default exept goRowSelect := True and PageMode := True

The grid is setted in this way

Grid datasource point to a TDataSet

The DataSet poit to a TFDQuery (already connect to a DataBase).

In the form create there is a simple query

TFDQuery.SQL.Add('Select * from Table1 INNER JOIN Table2 on (Table1.NUM=Table2.NUM) where');

TFDQuery.SQL.Add(' Table1.DATA = ' + QuotedStr(FormatDateTime('YYYY/MM/DD',Date)));


and the grid perform weel.

But if i filter the TFDQuery as


TFDQuery.Filter:='SellingType = 120';


The grid will display all the record according with the filter and if i move the cursor up/down with keyboard all works fine.

But if i try to move the cursor position with the mouse while the left button is pressed and the mouse exit from the bottom of the grid the scroll continue until the end of record is reached and, instead of stopping, the last record goes at the top of the grid (like first record), the rest of the grid's space is replaces with empty row and the cursor continue to go from the top to the bottom of the grid in an infinite loop until the left mouse button is released.

This append only if the DataSet is filtered, this does NOT append in your ADOEDIT demo (the only i tested) so it's possible is not a grid's problem.

Finally the question :

There's a possibility to disable the cursor changing position if the mouse button is pressed?

Example, if i click in the grid the cursor position change to the new row, but if i move the mouse while the button is still pressed the position does not change.

For information, now while the left button is pressed the mouse is moved outside the grid but on the top, the cursor does not scrolled up.

Sorry for the long message

Thank's for all


Did you set grid.DataSetType = dtNonSequenced?

With this setting, I could not see an issue here.

Hi Bruno thank's for reply.

I tried just now but this strange situation persist.

Due the fact that could not be a grid problem, there is the possiibilty to disable grid scrolling while left mouse button is pressed + mouse move in any direction?

Maybe not elegant but i prefer give the scroll via scroll bar or keyboard.

Thank's again

Have a good weekend


At this moment there isn't a setting that disables this. We'd need to investigate to extend the component to disable this specific functionality.

Thank's for this.

Merry Christmas