TAdvSpellCheck - running in a Service?

If I run as an application with the same code the application works.

If I run as a service I get the following error:
"An exception was raised on the server: Error reading spellchk1.Languages: Error reading TSpellCheckLanguagePack.AffixFileName: Cannot open file C:\WINDOWS\system32\English.aff.  The system cannot find the file specified"

I am also using the RemoteObjects SDK - a combo application that can either be an application or a service so I know the code flow is identical. 
The lat, aff, and SPLX files are 'supposed to be located in the same place as the .exe file.

As a Service the environment is different perhaps so the application and or spellcheck component does not see the startup folder as the loading folder?

PS-if I copy the lat aff and SPLX files to C:\WINDOWS\system32, --same error message so far.

Any advice is appreciated
thanks in advance

Sorry, we haven't tested spellcheck with services.

What happens when you put the spellcheck files in a non system folder and specify the absolute path to it?

Bruno
I have tried to specify the appropriate files for spellcheck object and it either made no difference or I did it wrong.

Here are some examples that I tried in the 'on create' event:
strStartPath is the location of the .exe
many things work when run as an application vs service.
Anything I can test for you?

spellchk1.Active := False;

     spellchk1.Languages.Clear;
     spellchk1.Languages.Add;
     //spellchk1..LoadFromFile(strStartPath + 'TMSSPELLCHECK.SPLX');
     //spellchk1.DatabaseFilename := strStartPath + 'TMSSPELLCHECK';
     spellchk1.LoadConfigFromString(ServerDataModule.strStartPath +
          'TMSSPELLCHECK.SPLX');
     //spellchk1.Languages[0].AffixFileName := strStartPath + 'English.aff';
     //spellchk1.Languages[0].SourceFileName :=strStartPath + 'English.lat';

regards and thank you again


Bruno

I noticed in debug mode that in unit TMSSpellCheck;
that the code
procedure TSpellCheckLanguagePack.SetAffixFilename(Value: TFileName);

gets called at least 2x if not 3x on initialization.

the first times the 'Value' only showed the text 'English.aff' but not the entire path.
and this causes the error.
the last time it is called the 'Value' shows the full path as in the code from my application,

I brute-forced trapped the an error as follows and it worked. Is not best practice, but
perhaps you can now update properly....
>>if (Value <> '') and FileExists(FixFileName(Value)) then
    begin;
      try
      SpellInfo.LoadFromFile(Value);
      except
      //do nothing on error -seems to get here 2 or 3x on start up-service gets past errors and works
      end;
    end;<<

This is now working as a service for spell checking...

Can it be you do a runtime creation of the TAdvSpellCheck component?

Bruno-
no I do not knowingly create the component at runtime.
-It is dropped on a unit design page
regards