I need to mask the TAdvSmoothDatePicker object, but I'm having a problem.

When I try to put the mask "!99/99/0000;1; " in EditMask property,
and I run the application, when I start writing on the object, it
does't work, for example, when I try to write the number 1, "  -  1 " appears on the screen and does't let me write the desired date.

Is there another way to put a mask on this object?

We traced & solved this issue. The next update will address this.


hope everything is ok with all TMS team under this pandemia situation.

I would like to know if you have a timeframe to release the update with this problem solved?

I would like to know it there is any easy way to clear a date on this kind field after it is fulfill. I think that must a way, but I am not finding it :).

Thank you for your support

Hermano Correia

We could reorganize & switch to tele-work and so far, we kept safe & healthy, thanks!

The fix for TAdvSmoothDatePicker is already in the latest TMS VCL UI Pack release. Did you check this latest release v10.2.5.0?