TAdvMemo and URL highlight bug (again)

I thought I'd give TAdvMemo another try after reporting a lot of bugs and I hoped they would be fixed by now but unfortunately not.

This is really frustrating.

See the screenshot where the URL highlighting is messed up because the words "for" and "displayed" and "information." are highlighted like they are a URL.

I still have not tested to see if the high DPI bugs have been fixed....

It is really frustrating to pay for these components and not to be able to use them even after reporting these issues months ago.


Can this bug finally be eradicated?

Thank you.

And when I click on the link with "F30" in it, it tries to take me to:


When it should take me to:

Not sure why it is appending the "for" to the end of the link when there is a space character in front of it.

By the way, here is the text contained in the TAdvMemo:

Ensure that images with empty or null alt text and no title attribute are decorative or should otherwise be ignored by assistive technology [A, 1.1.1; F30, H67] [A, 1.2.1; F30]. Visit https://www.w3.org/TR/WCAG20-TECHS/F30 and https://www.w3.org/TR/WCAG20-TECHS/H67 for more information. This message is displayed up to 3 times.
(Accessibility) Images may require a "longdesc" attribute to provide a URI that contains a long description that describes the image [A, 1.1.1; H45]. Visit https://www.w3.org/TR/WCAG20-TECHS/H45 for more information. This message is displayed up to 3 times.
Image searches can be a significant source of visitors and traffic. Therefore, try to use keywords when naming images, and separate keywords with hyphens (not underscores). This message is displayed only once.
[7] Ensure that the "img" element is rarely, if ever, used as a layout tool. Always use CSS for layout and positioning. This message is displayed only once.
GIF images are well supported in today's browsers but so are PNG images, which are, in many cases, superior to GIF because PNG images can support more colors, better transparency, and better compression (smaller file sizes). However, PNG does not support animation and may suffer from CSS color matching issues (visit https://www.htmlvalidator.com/CSEForum/viewtopic.php?f=3&t=1583). Consider using PNG images instead of GIF images if animation is not required. JPG is usually best for photographs. This message is displayed only once. There may be other GIF images specified in this document.
(Accessibility) If using an animated GIF (or other animated or updating content), then be sure that it is accessible. For example, make sure that content that blinks for more than five seconds has a mechanism to pause. Also, set animated gif images to stop blinking within 5 seconds. [A, 2.2.2; F7, G152]. Visit for https://www.w3.org/TR/WCAG20-TECHS/F7 and https://www.w3.org/TR/WCAG20-TECHS/G152 more information. This message is displayed only once.
6 messages for line 12

Good morning Albert,

reading your post i tried to made some test.

So i open Delphi 10.2 and, later, 10.3.1, new project, insert in a new form and only one tadvmemo with default setting.

I made 3 test, after inserting your above text, and the result are:

1 - With no wordwrap the text is handled in a rigth way, all link work in a rigth way

2 - With wordwrap setted to rigth margin, as default 80, the text is handled in a rigth way, the links don't work as expected in details

A) https://www.w3.org/TR/WCAG20-TECHS/H45 it's does not work because when you click on it the link show in chrome is https://www.w3.org/TR/WCAG20-TECHS/H45displayed

B) https://www.w3.org/TR/WCAG20-TECHS/F30 does not work because the link advmemo pass to browser is


(thake also the second link)

C) https://www.w3.org/TR/WCAG20-TECHS/H67 does not work beacuse the browser try to open https://www.w3.org/TR/WCAG20-TECHS/H67displayed

D) https://www.w3.org/TR/WCAG20-TECHS/H45 as above, the link passed is


Ther's the word "displayed" that caming from somewhere (not from the clipboard) that broke the component job. Also if there are 2 link close, the component see only one that is the link1 + link2.

3 - With wordwrap setted to client margin, dependig to component width, in this case i got all the errors you described and the links passed to browser are very dirthy, all are broken.

This is a serious problem.

So how to solve the problem?

This is a "non elegant" solution but one is better then zero.

Temporary, and if it's a non massive form rearrange, set the wordwrap to wwnone, increase advmemo width in order to see the maximum text and let the customer scroll the text with the bar. Becuse this is the only way the links work.

As told befor, it's not a good solution you expected, but till the team does not fix the issue i don't see any other solution.

Also, i hope gave to team a good way to fix the problems.

Have a good Easter


Hi Daniele,

Thank you for confirming this problem/bug and suggesting a workaround. Like you said, the workaround is not good.

I'll just continue to use another component that works. The only downside is that it does not make the links clickable. Hopefully TMS will squash this one because I am pretty darn sure I reported this months ago and I thought it had been fixed.

This must be related to wordwrap and we will reopen this case.

Has this been fixed yet? I have a new release coming up and I'd like to give it another try.

Hi TMS & Bruno,

Well, to answer my own question, I checked it again. TAdvMemo

Still not fixed.

This is very disappointing and discouraging. I still cannot use this component that I paid for and this has been a bug for a long time.

I don't understand how TAdvMemo can have so many features when it still can't properly highlight URLs.

We will reopen this case. We have been overwhelmed lately with work which caused a delay on some thing.


The next major release of my app is fast approaching.... and I would really like to use TAdvMemo if it can properly highlight and parse URLs.

Has this been fixed yet? The last I heard (from Bruno Fierens) in late July 2019 was that you guys have been "snowed under in work" and that this bug would be reopened and fixed once & for all.

Thank you.

We can confirm this issue was traced & solved.
The next TMS VCL UI Pack release will have this fix.

Great, thank you!

I'm testing out the component again and it does look like it will be usable (so far) but I did run into a bug where a link still wasn't highlighted and linked properly (and didn't work when I clicked on it).

The link that was not parsed properly: https://developers.facebook.com/docs/sharing/best-practices#images

It only parsed this much: https://developers.facebook.com/docs/sharing/best-

Also, the forum software gave me some weird 'Access denied' message when I first tried to post this message... and I had to go back and try again and reconstruct this message. Very annoying. Hope it works this time and this time I'm using copy and paste.

Sadly I found another bug.

In this case, the URL highlights properly, but when you click on it, it tries to open this link:

When it should open:

The text in the memo control is:
Images may require a "longdesc" attribute to provide a URI that contains a long description that describes the image [A, 1.1.1; H45]. Visit https://www.w3.org/TR/WCAG20-TECHS/H45 for more information. This message is displayed up to 3 times.
1 message for line 34

We have investigated & improved this. We have sent an incremental source update by email.

I am happy to report that TAdvMemo is not bug free enough that it is usable.

However, there are still URL highlighting and clicking bugs.

Take these two lines:
If you want to improve your website's search engine rankings, visit https://www.htmlvalidator.com/seo.html

The second line is "---".

It properly highlights the URL - "https://www.htmlvalidator.com/seo.html"

But when the highlighted URL is clicked on, it tries to go to "https://www.htmlvalidator.com/seo.html---". For some reason it is appending the 2nd line to the URL.

So it doesn't work when clicked on.

Hmmmm... I don't see any option to edit my messages.

That was suppose to be "I am happy to report that TAdvMemo is now bug free enough that it is usable."

Screenshot in case it is helpful:


We traced & solved the issue. The next update will address this.

Thank you!