Set URL parameters from within the Delphi IDE

I am developing a web application needing a few parameters in its URL. I am trying to set those parameters in the Delphi IDE, but I am probably doing something wrong, as I can't make it working.

However, when I restart the application and add the parameters manually, I can get them through Application.Parameters, as shown in the picture below.

I tried two ways to define parameters from the IDE:

  1. Run -> Parameters: fill in the required parameter here, as shown below. In this case, no parameters appears in de url. I also don't know how to add 2 parameters.

  1. Project -> Options -> TMS Web -> Compile -> URL Params, as shown below. Here also, no parameters appear in the URL.

I cannot see an issue here setting the param via URL params setting in TMS WEB project settings:

Thank your for your answer, but I get different results. To illustrate it, I made a small application analyzing the parameters: (1.6 MB)

The URL parameters are set as in your example:

Running the example gives an URL without parameters:

When adding the parameters manually, they are recognized:

I tested this here also out of curiosity. The parameter does not appear when I run a fresh WebCore app with F9 but it appears with Umsch+Ctrl+F9 (Run without debugger)...
WebCore 2.5.3 / Delphi 11.3 / Browser Edge

In your project, there was no question mark

When I added the question mark, it works

Thank you for your answer, but I still have a different result:

  • With or without the question mark, I can't see the parameters.
  • With the question mark, I see the parameters when starting the application with Ctrl Shift F9 instead of F9, as mentioned by Mr Thomas Feichtenschlager.

I am using Google Chrome, Delphi 12.1 and TMS WebCore V2540. (1.6 MB)

Confirmed issue when debugging from the IDE is enabled but internally fixed already.
Next update will address this.