Miletus MySQL Connection

I'm new here and have been trying to connect to VSC on Mac os with Miletus MySQL Connection for a month now, is there a small guide or example for this
Many thanks for your help


What were you the steps you have tried so far? Normally you can grab libmysqlclient.dylib from the bin or lib folder of the MySQL server installation. Running the installer might not add the dylib to the /usr/lib or /usr/local/lib folder so in that case you can try creating a symlink:

sudo ln -s /usr/local/mysql/lib/libmysqlclient.dylib /usr/local/lib/libmysqlclient.dylib

Where the first path points to the libmysqlclient.dylib from your server installation, so if it's different for you then make sure you are using the correct path.

I don't understand why I can't enter the name of the DataField in WebDBEdit -> DataField. I have to add the .dfm file manually what am I doing wrong. Thank you very much for your help

I'm not sure how to understand.
You cannot enter a value in the object inspector? What exactly happens when you want to enter it in the object inspector?
Did you try to set the DataField by code?

If I enter a value in the data field in the object inspector, it is immediately deleted
When I enter DataField = 'DBFieldname' in .dfm it works
Assurance is that the VSC Editor does not automatically recognize the DataField object DataSource already
Also if I pull up a button the first one has no cation the 2nd button has a value of 'WebButton1' and so on I don't know why it's VSC or TMS it's driving me crazy?

So, I assume you have via a DataSource no dataset connected that has fields?

I could not reproduce the issue with new TWebButton captions. Is this happening in a new Miletus project? Is this the latest version of TMS WEB Core?

Would be helpful if you post here an screenshot, so we can see what is going on. Thanks!

It is basically just a string property.

Test at runtime:

  webdbedit1.DataField := 'hello';

works as expected.

Is this only possible via unit source
webdbedit1.DataField := 'hello';

In the TODOLIST DEMO it looks like this

When I run TodoList Demo New Task and Update is OK Delete brings error

We'll investigate this.

We could see & fix the DataField editing issue.
We'll release an update to address this.

Thanks very much

You can just modify the MiletusFormCreate implementation the following way for now, this should get rid of the error. We'll update the demo on our end too.

procedure TForm1.MiletusFormCreate(Sender: TObject);
  WebDBGrid1.ColWidths[0] := 24;

  MiletusClientDataSet1.Indexes.Add('ByStatus', 'status',[]);
  MiletusClientDataSet1.ActiveIndex := 'ByStatus';

  MiletusClientDataSet1.Active := True;

Thanks for your help
Miletus MySQL Connection solved
With TMS web components the connection is very simple.
It is not advisable to use TMS Web Data Controls because the DataField is not recognized. Additional bugs when you want to enter data
The field loses focus after the first key press and jumps
in another field and writes there again a desert matter under VSC 1.76 - Mac os 10.15.7

Kind regards Siegfried Gogl

We have just updated TMS WEB Core for Visual Studio Code, version 2.0.6131, which includes the fix for the DataField property.

Can you please elaborate on the other issue? That is, is inside VSC or in an application you are running?

Thanks Jose that's going to be quick with the update, but try MiletusMySQLDBDriver1 with TMS Web and TMS Web Data Controls for yourself
Sigi G

This bug has not yet been fixed in the update
Sigi G