Miletus MainMenu not showing - no effect setting "Use Operating System theme"

I've been trying to use Miletus demos.
I use Windows in dark mode, and the TMiletusMainMenu main items are not showing in runtime. In PhotoEditor demo they're neither showing in design-time.
I tryed PhotoEditor and CodeEditor Demos.
I did as said in the documentation: Set "Use Operating System theme" to true, so it would enable automatic theming, but it didn't work.
What could be wrong?

The menu in a Miletus application is the operating system menu and not a menu rendered in HTML (like in a regular web application).
It is technically the same menu as when you use a TMainMenu in a VCL application. Do you see such menus?
Also, when you compile in debug mode, you should have the debug menu, do you see this?

Thats how it looks, either in release or debug mode. No other menu in debug mode.

If I press ALT+F, I can see this:

BTW, just after I posted it I noticed the main form Menu property was empty in PhotoEditor demo. Neither after setting to MainMenu1 it worked. It's visible while in design mode, but nothing happens in runtime - the same with CodeEditor demo.

After changing windows from dark to light theme, menus are correctly displayed:

Couldn't see a debug menu - the only weird thing I noticed was that when it's built with Debug Configuration, when I run it, for half a second it shows 4 main menu items: File, View, Windows and Help. Then the last three are hidden and only File remains visible. It happens either using "Run" or "Run without debugging". Doesn't happen when it's built with Release configuration.

Very strange it isn't displaying in dark theme.
Does it display in a regular VCL application with a TMainMenu on this machine in dark mode?



This is Miletus ToDoList demo.
I added a test TMiletusMainMenu with 2 subitems.
I've set "use operating system theme" to true.

Work fine with Windows light theme:

(When built with debug configuration, also show 3 additional menu items for half a second.)

Has the same behavior with windows dark theme. The menu "is there", but is not visible. Neither the space for the main menu bar is reserved. When I click ALT-T, it shows the subitems:

We were able to reproduce the issue and we are investigating it.

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.