Issue loading XLS on iOS and Android


I am using FMXGrid with the XLS brigde, however neither of the next code load the XLS, it close (crash) the entire form when sentences are called:


This applied only to Android or iOS, If I test on Windows it works fine, I'm using Alexandria 11.2 with latest FMX UI pack


Initially, the TMS FMX UI Pack version for the XLS bridge was 32 bit only. With the introduction of 64 bit, we applied changes to the XLS bridge, but only for TMS FNC UI Pack. We recommend to switch to TMS FNC UI Pack for future proof development. In the meantime we'll discuss here what the feasability is for integrating 64 bit in XLS bridge for TMS FMX UI Pack. Please note that TMS FMX UI Pack is a legacy product and is currently no longer actively developed.

This is not true, yesterday I make it worked but only in iOS, you can see for yourself on my next link:

So I need this works on Android too

Yes, I was referring to Android 64 bit and the way string indexing works. I'll investigate and see what we can do.

What happend?

As said, we'll investigate. Currently our planning is full, we'll see what the possibilities are for adding this to TMS FMX UI Pack. Note that TMS FMX UI Pack is in maintenance mode. New features are no longer added to this pack. If you want an immediate solution, you can use TMS FNC UI Pack where the XLS export is working.

It does not work on Android 32 bit as you wrote either, so there is not working on any Android.

I was hoping this bridge works on the platform above at minimum (Android 32).



I recorded 3 different videos in order to show you only iOS64 is working.

Sample of iOS working

Sample running on Android32, hangs with black screen

Sample running on Android64, close the form

You said Android32 is working but it's not, I need to import excel file on Android it does not matter if it is on 32 bits only.


I tried to install the bride for FNC but gaves me error.

C:\Program Files (x86)\Embarcadero\Studio\22.0\bin\dcc64.exe -$D0 -$L- -$Y- --no-config -M -Q -Z -TX.bpl -AGenerics.Collections=System.Generics.Collections;Generics.Defaults=System.Generics.Defaults;WinTypes=Winapi.Windows;WinProcs=Winapi.Windows;DbiTypes=BDE;DbiProcs=BDE;DbiErrs=BDE -DRELEASE;;FRAMEWORK_FMX -E.\Win64\Release -I"C:\Program Files (x86)\Embarcadero\Studio\22.0\lib\Win64\release";"C:\Users\Desarrollo\AppData\Local\tmssoftware\trial\TMSFNCUIPack RSXE14\Delphi11\Win64\Release";"C:\Users\Desarrollo\AppData\Local\tmssoftware\trial\TMSFNCUIPack RSXE14";\Delphi11\Win64\Release;C:\Users\Public\Documents\Embarcadero\Studio\22.0\Dcp\Win64;C:\Users\Desarrollo\Documents\TMSSoftware\FlexCelVCLNT\Packages\d11\Win64\Release;C:\Users\Public\Documents\Embarcadero\Studio\22.0\Dcp\Win64 -LEbpl\Win64 -LN.\Win64\Release -NU.\Win64\Release -NSWinapi;System.Win;Data.Win;Datasnap.Win;Web.Win;Soap.Win;Xml.Win;System;Xml;Data;Datasnap;Web;Soap; -O"C:\Program Files (x86)\Embarcadero\Studio\22.0\lib\Win64\release";"C:\Users\Desarrollo\AppData\Local\tmssoftware\trial\TMSFNCUIPack RSXE14\Delphi11\Win64\Release";"C:\Users\Desarrollo\AppData\Local\tmssoftware\trial\TMSFNCUIPack RSXE14";\Delphi11\Win64\Release;C:\Users\Public\Documents\Embarcadero\Studio\22.0\Dcp\Win64;C:\Users\Desarrollo\Documents\TMSSoftware\FlexCelVCLNT\Packages\d11\Win64\Release -R"c:\program files (x86)\embarcadero\studio\22.0\lib\Win64\release\EN";.\Win64\Release;"C:\Program Files (x86)\Embarcadero\Studio\22.0\lib\Win64\release";"C:\Users\Desarrollo\AppData\Local\tmssoftware\trial\TMSFNCUIPack RSXE14\Delphi11\Win64\Release";"C:\Users\Desarrollo\AppData\Local\tmssoftware\trial\TMSFNCUIPack RSXE14";\Delphi11\Win64\Release;C:\Users\Public\Documents\Embarcadero\Studio\22.0\Dcp\Win64;C:\Users\Desarrollo\Documents\TMSSoftware\FlexCelVCLNT\Packages\d11\Win64\Release -U"C:\Program Files (x86)\Embarcadero\Studio\22.0\lib\Win64\release";"C:\Users\Desarrollo\AppData\Local\tmssoftware\trial\TMSFNCUIPack RSXE14\Delphi11\Win64\Release";"C:\Users\Desarrollo\AppData\Local\tmssoftware\trial\TMSFNCUIPack RSXE14";\Delphi11\Win64\Release;C:\Users\Public\Documents\Embarcadero\Studio\22.0\Dcp\Win64;C:\Users\Desarrollo\Documents\TMSSoftware\FlexCelVCLNT\Packages\d11\Win64\Release;C:\Users\Public\Documents\Embarcadero\Studio\22.0\Dcp\Win64 --description:"TMS FNC Grid Excel Bridge for FMX (Runtime)" -JL -NB.\Win64\Release -NH.\Win64\Release -NO.\Win64\Release -H- -W- FMX_TMSFNCGridExcelBridge.dpk
Embarcadero Delphi for Win64 compiler version 35.0
Copyright (c) 1983,2022 Embarcadero Technologies, Inc.
C:\Users\Desarrollo\AppData\Local\tmssoftware\trial\TMSFNCUIPack RSXE14\FMXTMSFNCCorePkgDXE14.dpk(29): error E2225: Never-build package 'rtl' must be recompiled [C:\Users\Desarrollo\Documents\TMSSoftware\FNCExcelBridge\Packages\d11\FMX_TMSFNCGridExcelBridge.dproj]
FMX_TMSFNCGridExcelBridge.dpk(39): error E2202: Required package 'FMXTMSFNCCorePkgDXE14' not found [C:\Users\Desarrollo\Documents\TMSSoftware\FNCExcelBridge\Packages\d11\FMX_TMSFNCGridExcelBridge.dproj]
Done Building Project "C:\Users\Desarrollo\Documents\TMSSoftware\FNCExcelBridge\Packages\d11\FMX_TMSFNCGridExcelBridge.dproj" (default targets) -- FAILED.
Compilaci¢n del proyecto terminada "C:\Users\Desarrollo\Documents\TMSSoftware\FNCExcelBridge\Setup\fncpackbuild.msbuild" (Make destinos) -- ERROR.

ERROR al compilar.

"C:\Users\Desarrollo\Documents\TMSSoftware\FNCExcelBridge\Setup\fncpackbuild.msbuild" (Make destino) (1) ->
"C:\Users\Desarrollo\Documents\TMSSoftware\FNCExcelBridge\Packages\d11\FMX_TMSFNCGridExcelBridge.dproj" (destino predeterminado) (2) ->
(_PasCoreCompile destino) ->
C:\Users\Desarrollo\AppData\Local\tmssoftware\trial\TMSFNCUIPack RSXE14\FMXTMSFNCCorePkgDXE14.dpk(29): error E2225: Never-build package 'rtl' must be recompiled [C:\Users\Desarrollo\Documents\TMSSoftware\FNCExcelBridge\Packages\d11\FMX_TMSFNCGridExcelBridge.dproj]
FMX_TMSFNCGridExcelBridge.dpk(39): error E2202: Required package 'FMXTMSFNCCorePkgDXE14' not found [C:\Users\Desarrollo\Documents\TMSSoftware\FNCExcelBridge\Packages\d11\FMX_TMSFNCGridExcelBridge.dproj]

0 Advertencia(s)
2 Errores

Tiempo transcurrido 00:00:00.20

So what's the solution?

Please check the library path, it's an issue in RAD Studio 11.

I am on Alexandria 11.2, I can not install 11.3 right now

the FNC ui pack is correctly installed, the FNC brigde is the one gaves me error

You can read more about this issue here:

It's most likely a 64 bit path issue in your IDE.

I can not installed, I think the best solution is you take a look at the bridge for Tms Fmx UI pack and see why Android32 is not working, hangs once I loaded the xls file.

Hello again

I need the bridge can import excel files to Android on the FMX UI Pack I already renewed, forget about Android64 you wrote me that works in Android32 but I left you a video showing my app hangs an put on black screen.

I attempted to install the FNC ui pack without success, so what I paid was for maintenance and support for the FMX UI Pack, I am not asking you to develop new features.

Hope to heard from you soon