Android Cloud Storage Demo crash Android

Hi there:

I have just purchased TMS cloud.

Windows version of cloud storage demo works fine.


1.- Class TMSFMXCloudBitCasa is not present. I do not mid, I am not going to use it. But it is very disappointing to have this error in the demo. So I remove all the references to this class in the demo.

2.- I add the 2 TMS libraries and I disable android-support-v4.dex.

3.- I am checking only dropbox. I remove all the references to the rests of storages.. It connects to my dropbox account. It asks me permission...I click on allow.

4.- Then the application crashes. In Windows works and I can see the content of my Dropbox. In Android app crashes.

Any step is missed?

BTW, should I add a browser or not? Anyway, after adding TMSFMXCloudWebBrowser and select this option for dropbox, app crashes as well.

Let me add that I am using Tokyo version

Embarcadero did breaking changes in the Tokyo release for HTTP request handling on Android specifically (among other breaking changes that also affect Android). So, sadly, these breaking changes affect our cloud components. We are looking for workarounds for these breaking changes. Given the number of issues with the Android target, we'd really recommend to stick to Delphi 10.1 Berlin till we come up with workarounds and Embarcadero releases an update with fixes

Any news for Android? BTW, installing the April hotfix does not help. I do not want to move back to Berlin.

On the other hand, when I try to compile for iOS 64 bit (after adding this platform) the following error code appears:

[DCC Error] E2597 ld: file not found: /System/Library/Frameworks/SafariServices.framework/SafariServices

Please add the SafariServices framework to the SDK Manager by right-clicking the iOSDevice 64 target and clicking "Edit SDK". Click in the frameworks section and add a new framework based on the information below:

Ok. Now I can compile it...

But it closes when starting....


Can you please provide the following information so I can further investigate this?

- Which version of iOS are you using?
- Can the issue be reproduced in a new project created from scratch?
- Can you specify exactly when the issue occurs?
- Do you see any error messages when the issue occurs?

The app crashed before showing the form, when splash screen was visible.

I have removed this line in FormCreate

TFile.Copy(ExtractFilePath(ParamStr(0)) + 'sample.jpg', TPath.GetDocumentsPath + '/sample.jpg', True);

And now the app starts. However, when I click on connect, an error occurs:

Access violation at address 000000010075DD00, accessing address 000000000000001C

However, the same code, for Android, was able to connect to dropbox.

I am using the new last iPad model, with all the updates, iOS 10.3.2

Issue occurs when I click on connect button.

So, why must I have to remove that line? why this error when I click on connect?


Unfortunately there are issues with file deployment due to changes in the framework beyond our control.
We'll have to investigate if this issue can be fixed in a future version of the demo.

I see now that the app crashed because the file was not deployed. However, after removing that line of code, the app does not work yet.

I paid for a software that it does not work in Android,  and it seems it does not work in iOS, or at least I cannot run the demo.

Should I be happy?

We are currently working on a custom version of the CloudStorageDemo specifically for Android/iOS.

I will report back here as soon as possible after the demo is ready.

Any news?

No way to use it...

An updated version of the CloudStorageDemo will be included with the next release of TMS FMX Cloud Pack.
The release is planned for this week.

I am here again, trying to figure out how to use this product...if this is possible...  I am using Tokyo.

Yes, there is a new version of cloud storage. So first thing I do is installing this new version. OK.

Second thing, let's try compiling the new coludstrorage demo. way...

Old problems are not solved. For example, I have to delete some *.pas file that are not available. They are related to cloudBitCasa. A old problem not solved. Bad.

later I have to delete {$I tmsAPPIDS.INC}
 I have no idea why I must delete that. Bad.

 Error message "cannot stat C:\Cloudstoragedemo\bin\Cloustoragedemo.apk

1) if {$I tmsAPPIDS.INC} is deleted:
[DCC Fatal Error] CloudStorageDemo.dpr(5): F2048 Bad unit format: 'UCloudStorageDemo.dcu' - Expected version: 32.0, MaxOSX NX Language(ARM64) Found version: 32.0, Android NX Language(ARM)

2) if not deleted:
[DCC Fatal Error] UCloudStorageDemo.pas(31): F2048 Bad unit format: 'C:\Users\Paco\Documents\tmssoftware\TMS FMX Cloud Pack\FMX.TMSCloudDropBox.dcu' - Expected version: 32.0, MaxOSX NX Language(ARM64) Found version: 32.0, Android NX Language(ARM)



- Please note that the reference to the .INC file is there to enable saving the App Key and Secret values in an external file. There is a template available called "".

- References to BitCasa (which is indeed no longer supported) have been removed.
The update is included with the new release of the TMS FMX Cloud Pack available today.

- Can you please make sure to remove any existing DCU files before compiling for a specific platform?

What do you mean?

Let's try again...

I have downloaded and installed yesterday's version.

if a telephone is not connected to USB...success when compiling and building:

if a telephone is connected, error:

 Error message "cannot stat C:\Cloudstoragedemo\bin\Cloustoragedemo.apk

Now I understand the meaning the dcu files.

OK. after doing that.

[DCC Error] E2597 ld: can't open output file for writing: CloudStorageDemo, errno=13 for architecture arm64

I suspect this is a setup issue in your IDE for targetting iOS.
Are you able to deploy just any app / new app from the IDE to iOS?

Yes, I am deploying to iOS and OSX without any problems.

What about Android? why does not work when the telephone is connected?

Did you take in account page 9 of the PDF developers guide: