Hard Page Breaks Being Lost


We have the latest version.  We have a Properties data set and wish to print a page per property.  I tried putting a std Excel page break inside a  Properties named range.  This works for only the first Property.  That is, it inserts the page break at the end of the first property but after that there are no more page breaks inserted.

I have worked around this on a few sheets using auto page break and Keeprows but it is unnecessarily kludgy and it would be much better if I could just use standard page breaks.  It is a simple enough requirement and I am at a loss to see what we are doing wrong.  We tried something similar in the demo sheets/code provided and are seeing similar behaviour.

Is this a known problem?  Can anyone else reproduce it?



Even when I agree it is a weird behavior, sadly it is "as designed". This is because Excel doesn't copy the hard page breaks when you copy rows, so, as we try to mimic as well as possible how Excel behaves, we don't copy them either. I am not really sure on why it is that way, but well, maybe copying page breaks doesn't make too much sense in normal use.

But FlexCelReport uses the standard copy functionality, and as it doesn't copy page breaks, the reports won't copy them either.

Luckily there is a simple solution, there is a tag <#page break> that was created just because of this issue, and you can use in the template instead of inserting a hard page break directly. This tag will be copied and behave as expected. for column page breaks you can use <#column page break> instead.