Grid + Navigator


I'm using the grid control on an Android device. The form also has a database navigator control on it. The database is SQLite via FireDAC.

Clicking the Refresh button does refresh the grid's display.

However, using the first / prior / next / last buttons does not seem to move the position of the "selected" or "highlighted" row.

Is this the intended behavior?

How do I get a navigator control to work with your grid?

Brian Wheatley

Is everything setup correct with livebindings?
Did you have a look at our Grid Livebindings demo that has a navigator & grid?

As far as I can tell everything is setup correct with livebindings. I dropped a TEdit on the form and the value changes when I click the navigation buttons (next, prior, etc.).

The Livebinding demo uses a client data set and I'm using FireDAC. Also, the demo has a TBindScopeDB instead of TBindSourceDB and I can't seem to find TBindScope in the tool box.


Are you able to reproduce this with TGrid or TStringGrid? Did you bind the DBNavigator to the Datasource which is bound to the dataset?

Kind Regards, 

I've tried everything that I can think of and it does not work.

TGrid and TStringGrid throw EArgumentOutOfRangeException when the application starts even though everything looks proper at design time (column names, etc.).

The configuration is shown in the images below.

Thank you,
Brian Wheatley

Perhaps you could try to make it work with TGrid and / or TStringGrid first, because if there is an issue in one of these components then the issue will most likely occur in TTMSFMXGrid. Did you drop a navigator on the form from the tool palette or did you right-click the datasource and selected add navigator?

Kind Regards, 

I'll have to get with Embarcadero on why the TGrid / TStringGrid controls don't work.

All of the controls were placed on the respective forms from the tool box.

I tried to submit the project via the support form but I'm not sure if the e-mails got through or not.

This is the simplest project possible.

On the data module:

FDConnection configured for a SQLite database with one table (customers)
FDTable set to the Customers table via the FDConnection
TDataSource with the FDTable as the DataSet
TBindSourceDB with the TDataSource and FDTable as the DataSource and DataSet respectively

On the main form:

The navigator and the grid are both bound to the TBindSourceDB.

All of the data displays properly in the grid but the row navigation does not work.